カテゴリ:

IOSでルータなどの設定を行っているときに、直接設定ファイル(running-config)を見ることがありますが、show running-configをそのまま実行するのはあまり便利とは言えません。遅いルータであれば時間がかかるし、そもそも全体を表示すると必要な部分を探すのが面倒です。

パイプ"|"を活用することで、running-configをより見やすくすることが可能です。

R1#show version | include IOS
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)
R1#show running-config | ?
  append    Append redirected output to URL (URLs supporting append operation
            only)
  begin     Begin with the line that matches
  exclude   Exclude lines that match
  include   Include lines that match
  redirect  Redirect output to URL
  section   Filter a section of output
  tee       Copy output to URL

例えばOSPFの設定を確認する時に"begin"を使います。"begin"の引数に指定した文字列に一致した行以降が表示されることが分かります。

R1#show running-config | begin router ospf
router ospf 1
router-id 17.17.1.1
log-adjacency-changes
network 12.12.12.1 0.0.0.0 area 0
network 17.17.1.1 0.0.0.0 area 0
!
〜略〜

上記の例はOSPFの設定値が確認できましたが、"include"を利用すると引数に指定した文字列を含む行のみを表示できます。

R1#show running-config | include ospf
ip ospf priority 0
router ospf 1

上記の例でインターフェイスにプライオリティが指定されていることが分かります。"section"を利用すると関連した設定値がまとめて表示できます。

R1#show running-config | section ospf
ip ospf priority 0
router ospf 1
router-id 17.17.1.1
log-adjacency-changes
network 12.12.12.1 0.0.0.0 area 0
network 17.17.1.1 0.0.0.0 area 0

インターフェイスの設定を確認するにはパイプは不要で、そのままインターフェイス名を指定します。

R1#show running-config interface fastEthernet 0/0
Building configuration...

Current configuration : 94 bytes
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
speed 100
full-duplex
end

最後に"linenum"を指定すると行番号の表示が可能です。

R1#show running-config linenum
Building configuration...

Current configuration : 1525 bytes
     1 : !
     2 : ! Last configuration change at 15:48:13 JST Mon Dec 20 2010
     3 : !
     4 : version 12.4
     5 : service timestamps debug datetime msec
〜略〜