IPv6

ƥ:

IPv6 RIPˤϩνԤޤR1R2F0/0³ƤơLo0ȶˤ줾󥯥륢ɥ쥹ꤷƤޤR2Lo0ˤϽǻȤɥ쥹4ɲäޤ

R1(config)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::1
Loopback0                  [up/up]
    FE80::1

R2(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::2
Loopback0                  [up/up]
    FE80::2
    2001:0:0:2::2
    2001:0:0:22::2
    2001:0:0:222::2
    2001:0:0:2222::2

R1R2F0/0RIPͭˤޤ

R1(config)#do sh run int f0/0
ά
interface FastEthernet0/0
ipv6 address FE80::1 link-local
ipv6 rip RIP6 enable

R1(config)#do deb ipv rip
RIP Routing Protocol debugging is on
R1(config)#do sh ipv rip RIP6
RIP process "RIP6", port 521, multicast-group FF02::9, pid 246
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 58, trigger updates 11
  Interfaces:
    Loopback0
    FastEthernet0/0
  Redistribution:
    None

R1Υ롼ƥ󥰥ơ֥R2Υɥ쥹ɽ뤳Ȥʬޤ

R1(config-if)#do sh ipv rou rip
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   2001:0:0:2::/64 [120/2]
     via FE80::2, FastEthernet0/0
R   2001:0:0:22::/64 [120/2]
     via FE80::2, FastEthernet0/0
R   2001:0:0:222::/64 [120/2]
     via FE80::2, FastEthernet0/0
R   2001:0:0:2222::/64 [120/2]
     via FE80::2, FastEthernet0/0

4ĤΥɥ쥹ping¹Ԥޤ

R1(config)#do pin 2001:0:0:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/28 ms
R1(config)#do pin 2001:0:0:22::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:22::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms
R1(config)#do pin 2001:0:0:222::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:222::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
R1(config)#do pin 2001:0:0:2222::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:2222::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms

pingμ¹ԤǧǤΤǽԤޤѤΤipv6 rip summary-addressޥɤǡǤñ/64/48˽󤷤ޤޥɤꤹΤϽ󥢥ɥ쥹ή󥿡եǡξR2F0/0Ѥޤ

R2(config-if)#int f0/0
R2(config-if)#ipv rip RIP6 summary-address 2001::/48

RIPǤΤͤOSPFEIGRPȰ㤤ȿǤ˻֤ޤCCIE Labʤ᤯̤ˤϥ󥿡եshut롼ƥ󥰥ơ֥äƤno shutޤ

塢ǧȲΤ褦ˤäꤷˤʤޤ

R1(config)#do sh ipv rou rip
IPv6 Routing Table - 2 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   2001::/48 [120/2]
     via FE80::2, FastEthernet0/0

ping¹ԤޤǤforeachȤäƤޤCCIE Labˤ¿Υɥ쥹Фping¹ԤޤΤǡforeachλȤФǤ

R1(tcl)#foreach router {
+>(tcl)#2001:0:0:2::2
+>(tcl)#2001:0:0:22::2
+>(tcl)#2001:0:0:222::2
+>(tcl)#2001:0:0:2222::2
+>(tcl)#} { puts [ exec "ping $router"]}

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/16 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:22::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:222::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:2222::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms

R1(tcl)#tclquit

ƥ:

IPv6RIPǥȥåꤹˡǧޤR1R2F0/0S1/0(ե졼졼)ľ³Ƥޤ

R1(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::1
Serial1/0                  [up/up]
    FE80::1

Loopback0                  [up/up]
    FE80::1
    2001:1::1

R2(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::2
Serial1/0                  [up/up]
    FE80::2
Loopback0                  [up/up]
    FE80::2
    2001:2::2

R1(config)#do pin fe80::2
Output Interface: fastethernet0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::2, timeout is 2 seconds:
Packet sent with a source address of FE80::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
R1(config)#do pin fe80::2
Output Interface: serial1/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::2, timeout is 2 seconds:
Packet sent with a source address of FE80::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/9/24 ms

R1R2줾F0/0, S1/0, Lo0IPv6 RIPͭˤޤ

R1(config)#int f0/0
R1(config-if)#ipv6 rip RIP6 enable
R1(config-if)#int s1/0
R1(config-if)#ipv6 rip RIP6 enable
R1(config-if)#int lo0
R1(config-if)#ipv6 rip RIP6 enable
R1(config-if)#do sh ipv rip RIP6
RIP process "RIP6", port 521, multicast-group FF02::9, pid 255
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 103, trigger updates 6
  Interfaces:
    Serial1/0
    FastEthernet0/0
    Loopback0
  Redistribution:
    None

R1R2ؤLo0ɥ쥹(2001:2::2)ؤΥ롼Ȥǧޤȥå2ǡ2ĤΥ󥿡եѤƤ뤳Ȥʬޤ

R1(config-if)#do sh ipv rou 2001:2::2
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   2001:2::/64 [120/2]
     via FE80::2, FastEthernet0/0
     via FE80::2, Serial1/0

R1Υ󥿡եǥȥåͤꤷƤߤޤipv6 rip RIP6 metric-offsetޥɤѤ3ꤷƤߤޤ

R1(config-if)#int f0/0
R1(config-if)#ipv6 rip RIP6 metric-offset 3
R1(config-if)#int s1/0
R1(config-if)#ipv6 rip RIP6 metric-offset 3
R1(config-if)#do deb ipv6 rip
RIP Routing Protocol debugging is on

ȥåǽ2(1+1)4(1+3)ѹ줿Ȥʬޤ

R1(config-if)#do sh ipv rou 2001:2::2
ά
R   2001:2::/64 [120/4]
     via FE80::2, Serial1/0
     via FE80::2, FastEthernet0/0

F0/0Τߡȥå5ѹޤˤF0/0롼ƥ󥰤ä뤳Ȥʬޤ

R1(config-if)#int f0/0
R1(config-if)#ipv6 rip RIP6 metric-offset 5

R1(config-if)#do sh ipv rou 2001:2::2
ά
R   2001:2::/64 [120/4]
     via FE80::2, Serial1/0

ηϩ򤢤ƻȤʤ褦ˤˡmetric-offsetϤ褯Ȥޤ

ƥ:

ϥե졼졼IPv6ԤޤŪˤIPv4ƱǤR1S1/0DLCI 102R2S1/0DLCI 201Ȥä³Ԥޤ

R1ǤǤץ벽IPɥ쥹ꤷƤޤDLCIŪѤ뤿ᡢinverse-arp̵ˤޤ

R1(config)#int s1/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no sh
R1(config-if)#no fram inverse-arp
R1(config-if)#ipv6 address fe80::1 link-local

DLCIframe-relay mapǻꤷǧޤ

R1(config-if)#frame-relay map ipv6 fe80::2 102 broadcast
R1(config-if)#do sh fram map
Serial1/0 (up): ipv6 FE80::2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

R2ǤƱ褦ꤷޤ

R2(config)#int s1/0
R2(config-if)#no sh
R2(config-if)#en fram
R2(config-if)#no fram inv
R2(config-if)#ipv add fe80::2 li
R2(config-if)#fram map ipv6 fe80::1 201 b
R2(config-if)#do sh fram map
Serial1/0 (up): ipv6 FE80::1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active

ξΥ󥿡եup/upˤʤäƤ뤳Ȥʬޤping̤ǧޤ

R1(config-if)#do sh ipv int b
Serial1/0                  [up/up]
    FE80::1

R2(config-if)#do sh ipv int b
Serial1/0                  [up/up]
    FE80::2

R1(config-if)#do pin fe80::2
Output Interface: serial1/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::2, timeout is 2 seconds:
Packet sent with a source address of FE80::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/16 ms

ʤLMIפפʤ³Ǥޤ󡣲ϤLMIפCISCOѤƤǤ

R1(config-if)#do sh int s1/0 | i LMI type
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE  segmentation inactive
R1(config-if)#do deb fram lmi
Frame Relay LMI debugging is on
Displaying all Frame Relay LMI data

R1(config-if)#frame-relay lmi-type cisco

Aug 15 06:07:09.215: Serial1/0(out): StEnq, myseq 3, yourseen 0, DTE up
Aug 15 06:07:09.219: datagramstart = 0xF400714, datagramsize = 13
Aug 15 06:07:09.219: FR encap = 0xFCF10309
Aug 15 06:07:09.219: 00 75 01 01 01 03 02 03 00
Aug 15 06:07:09.223:
Aug 15 06:07:19.215: Serial1/0(out): StEnq, myseq 1, yourseen 0, DTE down

R1(config-if)#do sh ipv int b
Serial1/0                  [up/down]
    FE80::1

LMIפ򸵤ᤷLo0ˤIPv6ɥ쥹ꤷޤ

R1(config-if)#do sh ipv int b
Serial1/0                  [up/up]
    FE80::1
Loopback0                  [up/up]
    FE80::1
    2001:1::1

ƤΥ󥿡եRIPͭˤޤ

R1(config-if)#do sh ipv6 rip
RIP process "RIP6", port 521, multicast-group FF02::9, pid 255
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 1, trigger updates 2
  Interfaces:
    Loopback0
    Serial1/0
  Redistribution:
    None

ͤˡIPv6ǥե졼졼ѤǤ롼ƥ󥰤ϴŪƱǤ

R1(config-if)#do sh ipv rou rip
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   2001:2::/64 [120/2]
     via FE80::2, Serial1/0
R1(config-if)#do pin 2001:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/12 ms

ƥ:

ϥ󥿡եIPv6ɥ쥹ꤹ롢Ūˡޤ

R1(config-if)#do sh run int f0/0
Building configuration...

Current configuration : 72 bytes
!
interface FastEthernet0/0
no ip address
end

ü᤯IPv6ͭˤˤipv6 enableѤޤ

R1(config-if)#int f0/0
R1(config-if)#ipv6 enable

R1(config-if)#do sh run int f0/0
Building configuration...

Current configuration : 85 bytes
!
interface FastEthernet0/0
no ip address
ipv6 enable
end

R1(config-if)#do sh ipv int b   
FastEthernet0/0            [up/up]
    FE80::C000:12FF:FE13:0

R2ˤƱ褦ꤷޤ

R2(config-if)#int f0/0
R2(config-if)#ipv en
R2(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::C001:12FF:FE13:0

R1ping̤뤳Ȥǧޤ

R2(config-if)#do pin  FE80::C000:12FF:FE13:0
Output Interface: fastethernet0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::C000:12FF:FE13:0, timeout is 2 seconds:
Packet sent with a source address of FE80::C001:12FF:FE13:0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/16 ms

Х륢ɥ쥹ƤˤϼưMACɥ쥹ѤEUIޤ

ޤưǤγƤǤIPv4Ȱ㤤secondary addressȤʤƤ⡢ΤޤʣΥɥ쥹ǽǤ

R1(config-if)#int f0/0
R1(config-if)#ipv add 2001:1::1/64
R1(config-if)#ipv add 2001:1::10/64
R1(config-if)#ipv add 2001:1::100/64
R1(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::C000:12FF:FE13:0
    2001:1::1
    2001:1::10
    2001:1::100

R2EUIȤäꤷƤߤޤMACɥ쥹ѤƤ뤳Ȥʬޤ

R2(config-if)#int f0/0
R2(config-if)#ipv address 2001:2::/64 ?
  anycast  Configure as an anycast
  eui-64   Use eui-64 interface identifier
  <cr>

R2(config-if)#ipv address 2001:2::/64 eui-64
R2(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::C001:12FF:FE13:0
    2001:2::C001:12FF:FE13:0

R2(config-if)#do sh ipv int f0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::C001:12FF:FE13:0
ά

ƥ:

IPv6ˤ륢ꥹȤˡǧޤߡR1R2EIGRPѤƤޤ

R1#show ipv6 interface b
FastEthernet0/0            [up/up]
    FE80::1
Loopback0                  [up/up]
    FE80::1
    2001:1::1

R2#show ipv6 interface brief
FastEthernet0/0            [up/up]
    FE80::2
Loopback0                  [up/up]
    FE80::2
    2001:2::2

R1#show ipv6 route eigrp
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   2001:2::/64 [90/156160]
     via FE80::2, FastEthernet0/0

R1#ping 2001:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

¤򤫤Ƥʤ֤ǤR1F0/0Lo0ξtelnet³ǽǤ

R1#telnet 2001:2::2 /source-interface f0/0
Trying 2001:2::2 ... Open

User Access Verification

Password:
R2>

R1#telnet 2001:2::2 /source-interface lo0
Trying 2001:2::2 ... Open

User Access Verification

Password:
R2>show users
    Line       User       Host(s)              Idle       Location
   0 con 0                idle                 00:00:16   
* 98 vty 0                idle                 00:00:00 2001:1::1

  Interface    User               Mode         Idle     Peer Address

R2IPv6ǤΥꥹȤȤ³¤ԤޤIPv6ꥹȤǤ̾դΤߤѲǽǤϲƯǧ뤿logäޤ

R2(config)#ipv6 access-list TELNET
R2(config-ipv6-acl)#permit ipv6 2001:1::/64 host 2001:2::2 log
R2(config-ipv6-acl)#do sh ipv ac
IPv6 access list TELNET
    permit ipv6 2001:1::/64 host 2001:2::2 log sequence 10

ꥹȤline vtyŬѤޤ

R2(config-ipv6-acl)#line vty 0 4
R2(config-line)#ipv6 access-class TELNET in

³ǧޤޤf0/0(fe80::1)Ǥ³ݤޤ

R1#telnet 2001:2::2 /source-interface f0/0
Trying 2001:2::2 ...
% Connection refused by remote host

lo0(2001:1::1)³꤬ʤȤʬޤ

R1#telnet 2001:2::2 /source-interface lo0
Trying 2001:2::2 ... Open

User Access Verification

Password:
R2

R2ˤϲΤ褦˥ɽޤ

R2(config-ipv6-acl)#
Aug  1 06:06:28.675: %IPV6-6-ACCESSLOGP: list TELNET/10 permitted tcp 2001:1::1(13418) -> 2001:2::2(23), 1 packet

R2(config-ipv6-acl)#do sh ipv ac
IPv6 access list TELNET
    permit ipv6 2001:1::/64 host 2001:2::2 log (2 matches) sequence 10

ꥹȤݤ̾դΤߤͭȤʳϡŪIPv4ƱͤѤǤޤ

ƥ:

IPv6ǤδŪEIGRPǧƤޤIPɥ쥹ƱǤ

R1(config)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::1
Loopback0                  [up/up]
    FE80::1
    2001:1::1

R2(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::2
Loopback0                  [up/up]
    FE80::2
    2001:2::2

IPv6ǤΥ롼ƥ󥰤R1R2ͭˤޤ

R1(config)#ipv6 unicast-routing

EIGRPΥץͭˤޤ

R1(config)#ipv6 router eigrp 100

Ƥä꤬ɬפǤץno shutdown¹ԤɬפΤǤ¹ԤʤEIGRPͭˤʤޤ

R1(config-rtr)#no shutdown

󥿡եEIGRPͭˤRIPOSPFƱǤR2ǤƱ褦ˤͭˤޤ

R1(config-rtr)#int f0/0
R1(config-if)#ipv6 eigrp 100
R1(config-if)#int lo0
R1(config-if)#ipv6 eigrp 100

show ipv6 protocolޥɤͭʥ󥿡եǧޤ

R1(config-if)#do sh ipv prot
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "static"
IPv6 Routing Protocol is "eigrp 100"
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Interfaces:
    FastEthernet0/0
    Loopback0
  Redistribution:
    None
  Maximum path: 16
  Distance: internal 90 external 170

show ipv6 eigrp interfaceޥɤǤͭʥ󥿡եǧǤޤ

R1(config)#do sh ipv ei int
IPv6-EIGRP interfaces for process 100

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              1        0/0        20       0/1           50           0
Lo0                0        0/0         0       0/1            0           0

IPv4Ʊ褦IPv6ǤEIGRPϤ³ͭˤʤޤ

R1(config-if)#do sh ipv ei nei
IPv6-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Fa0/0             14 00:00:37   20   200  0  4
    FE80::2

show ipv6 eigrp topologyޥɤ¹Ԥȡlo0ǤΥͥåȥEIGRPήƤ뤳ȤǧǤޤ

R1(config)#do sh ipv ei top
IPv6-EIGRP Topology Table for AS(100)/ID(17.17.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 2001:1::/64, 1 successors, FD is 128256
        via Connected, Loopback0
P 2001:2::/64, 1 successors, FD is 156160
        via FE80::2 (156160/128256), FastEthernet0/0

R1IPv6Υ롼ƥ󥰥ơ֥ǧping¹Խ뤳Ȥǧޤ

R1(config)#do sh ipv rou ei
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   2001:2::/64 [90/156160]
     via FE80::2, FastEthernet0/0

R1(config)#do pin 2001:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms

ƥ:

IPv6ǤδŪOSPFǧƤޤIPɥ쥹ƱǤ

R1(config)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::1
Loopback0                  [up/up]
    FE80::1
    2001:1::1

R2(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::2
Loopback0                  [up/up]
    FE80::2
    2001:2::2

IPv6ǤΥ롼ƥ󥰤R1R2ͭˤޤ

R1(config)#ipv6 unicast-routing

IPv6ǤOSPFǤϥץIDꤷƵưޤޤ롼IDꤷޤIPv4ɥ쥹ηǤλȤʤޤ

R1(config)#ipv6 router ospf 1
R1(config-rtr)#router-id ?
  A.B.C.D  OSPF router-id in IP address format

R1(config-rtr)#router-id 17.17.1.1

IPv6Ǥϥ󥿡եñ̤OSPFͭꤷޤϥꥢ0Ѥޤ

R1(config-rtr)#int f0/0
R1(config-if)#ipv6 ospf 1 area 0
R1(config-if)#int lo0
R1(config-if)#ipv6 ospf 1 area 0

󥿡եͭǤ뤳Ȥǧޤ

R1#show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "static"
IPv6 Routing Protocol is "ospf 1"
  Interfaces (Area 0):
    Loopback0
    FastEthernet0/0
  Redistribution:
    None

R1#show ipv6 ospf interface brief
Interface    PID   Area            Intf ID    Cost  State Nbrs F/C
Lo0          1     0               13         1     LOOP  0/0
Fa0/0        1     0               4          1     BDR   1/1

R1#debug ipv6 ospf adj
Jul 19 06:41:17.519: OSPFv3: Send LS REQ to 17.17.2.2 length 12 LSA count 1
Jul 19 06:41:17.519: OSPFv3: Send DBD to 17.17.2.2 on FastEthernet0/0 seq 0xDE7 opt 0x0013 flag 0x0 len 28
Jul 19 06:41:17.523: OSPFv3: Rcv LS REQ from 17.17.2.2 on FastEthernet0/0 length 40 LSA count 2
Jul 19 06:41:17.523: OSPFv3: Send UPD to 101.11.13.108 on FastEthernet0/0 length 80 LSA count 2
Jul 19 06:41:17.531: OSPFv3: Rcv LS UPD from 17.17.2.2 on FastEthernet0/0 length 44 LSA count 1
Jul 19 06:41:17.531: OSPFv3: Synchronized with 17.17.2.2 on FastEthernet0/0, state FULL
Jul 19 06:41:17.531: %OSPFv3-5-ADJCHG: Process 1, Nbr 17.17.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done

󥿡եξܺ٤ɽȥͥåȥפ䥳ȤʤɡIPv4ȴŪƱǤ뤳Ȥ褯ʬޤ

R1#show ipv6 ospf interface brief f0/0
FastEthernet0/0 is up, line protocol is up
  Link Local Address FE80::1, Interface ID 4
  Area 0, Process ID 1, Instance ID 0, Router ID 17.17.1.1
  Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 17.17.2.2, local address FE80::2
  Backup Designated router (ID) 17.17.1.1, local address FE80::1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 17.17.2.2  (Designated Router)
  Suppress hello for 0 neighbor(s)

ꤵ줤륨ꥢǧޤХåܡǤArea 0꤬ǧǤޤ

R1#show ipv6 ospf 1
Routing Process "ospfv3 1" with ID 17.17.1.1
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        SPF algorithm executed 2 times
        Number of LSA 6. Checksum Sum 0x02B316
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

R2Ȥ³֤ǧޤFULLȤʤäƤ뤳Ȥʬޤ

R1#show ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
17.17.2.2         1   FULL/DR         00:00:32    4               FastEthernet0/0

IPv6Υ롼ƥ󥰥ơ֥򸫤ȡR2Lo0ܤäƤ뤳Ȥʬޤ

R1#show ipv6 route ospf
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
O   2001:2::2/128 [110/1]
     via FE80::2, FastEthernet0/0

pingޥɤ̤ǧƤޤ

R1#ping 2001:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/12 ms

ƥ:

IPv6ǤRIPꤷޤޤ¤ǡưIPv4Ȥΰ㤤Ǥ褦ˤޤ

R1R2F0/0ľ³ƤޤF0/0Lo0ˤ줾󥯥륢ɥ쥹ꤷLo0ˤϤ줾IPv6ɥ쥹(2001:1::1, 2001:2::2)Ƥޤ4ĤΥ󥿡եRIPͭˤޤ

R1(config)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::1
Loopback0                  [up/up]
    FE80::1
    2001:1::1

R2(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::2
Loopback0                  [up/up]
    FE80::2
    2001:2::2

ޤξ롼IPv6ǤΥ롼ƥ󥰤ͭȤ뤿ipv6 unicast-routingޥɤ¹Ԥޤ

R1(config)#ipv6 ?
ά
  unicast-routing    Enable unicast routing
R1(config)#ipv6 unicast-routing

RIPѤ륤󥿡եipv6 rip¹ԤޤIPv4Ǥrouter ripnetworkޥɤѤ뤳Ȥǥ󥿡եꤷޤIPv6Ǥľܥ󥿡եѤΤħǤ

ipv6 ripޥɤRIPΥץͭˤޤǤդʸץ̾ȤƻꤷޤǤRIP6Ȥޤ4ĤΥ󥿡եƱԤޤ

R1(config)#int f0/0
R1(config-if)#ipv6 rip RIP6 enable

嵭ˤꡢưŪ˥Х ե졼 ޥɤǤipv6 router ripꤵޤ

R1(config-if)#do sh run | i RIP6
ipv6 rip RIP6 enable
ipv6 router rip RIP6

󥿡եͭˤʤäƤ뤫show ipv6 protocolsޥɤdzǧƤޤ

R1#show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "static"
IPv6 Routing Protocol is "rip RIP6"
  Interfaces:
    Loopback0
    FastEthernet0/0
  Redistribution:
    None

debugDzƯǧޤ

R1#debug ipv6 rip f0/0
Jul 11 06:11:38.583: RIPng: Sending multicast update on FastEthernet0/0 for RIP6
Jul 11 06:11:38.583:        src=FE80::1
Jul 11 06:11:38.587:        dst=FF02::9 (FastEthernet0/0)
Jul 11 06:11:38.587:        sport=521, dport=521, length=32

R2ǥ롼ȤǧȳΤRIPˤR1ξɽƤޤ

R2#show ipv6 route rip
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   2001:1::/64 [120/2]
     via FE80::1, FastEthernet0/0

pingޥɤ̤ǧޤ

R2#ping 2001:1::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

ƥ:

IPv6Ҳ𤷤ޤCCIE LabǤϥ󥿡եIPɥ쥹ꤹ٤˴ñǤߤϤʣФޤΤǤäȳؽƤɬפޤ

ޤIPɥ쥹ꤷޤǤñˡipv6 enableޥɤޤ

R1(config)#int f0/0
R1(config-if)#ipv6 enable
R1(config-if)#no sh
R1(config-if)#do sh ipv6 int b
FastEthernet0/0            [up/up]
    FE80::C000:34FF:FE43:0
ά
R1(config-if)#do sh ipv6 int f0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::C000:34FF:FE43:0 [TEN]
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
ά

嵭ͤfe80ǻϤޤ󥯥륢ɥ쥹ꤵޤΥɥ쥹ϥ󥿡եMACɥ쥹꼫ưŪޤΥɥ쥹ܤǥХ֤ΤߤͭǤ

f0/0³ǤR2f0/0ˤƱԤޤ

R2(config)#int f0/0
R2(config-if)#ipv6 enable
R2(config-if)#no sh

ƤΤޤping¹ԲǽǤ󥯥륢ɥ쥹ѤݤѤ륤󥿡եꤹɬפޤ

R2(config-if)#do pin FE80::C000:34FF:FE43:0
Output Interface: FastEthernet0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::C000:34FF:FE43:0, timeout is 2 seconds:
Packet sent with a source address of FE80::C001:34FF:FE43:0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/52 ms

MACɥ쥹Ѥ󥯥륢ɥ쥹ʤΤΡIPɥ쥹ʣȤʤꤢޤȤ䤹Ȥϸޤ󡣸ǻꤹˤϲΤ褦ˤޤ

R1(config-if)#int f0/0
R1(config-if)#ipv6 address fe80::1 link-local
R1(config-if)#do sh ipv int b
FastEthernet0/0            [up/up]
    FE80::1

R2(config-if)#int f0/0
R2(config-if)#ipv6 address fe80::2 link-local
R2(config-if)#do ping fe80::1

R1fe80::1R2fe80::2ȳФ䤹ɥ쥹ˤʤޤƤΥ󥯥륢ɥ쥹ƤΥ󥿡եƱΤǤޤĤޤR1Υ󥿡եf0/0, f0/1, s1/0, s1/1Ƥfe80::1ǽǤ

˥ե졼졼ǤǧޤIPv4ξƱ褦DLCIꤹե졼졼ޥåפɬפǤ

R1(config-if)#int s1/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#ipv6 address fe80::1 link-local
R1(config-if)#frame-relay map ipv6 fe80::2 102 broadcast
R1(config-if)#no sh
R1(config-if)#do sh fram map
Serial1/0 (up): ipv6 FE80::2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

R2ǤԤping¹Խ뤳ȤǧƤޤ

R2(config-if)#int s1/0
R2(config-if)#en fram
R2(config-if)#ipv6 address fe80::2 link-local
R2(config-if)#frame-relay map ipv6 fe80::1 201 broadcast
R2(config-if)#no sh
R2(config-if)#do sh fram map
Serial1/0 (up): ipv6 FE80::1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active
R2(config-if)#do ping fe80::1
Output Interface: Serial1/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::1, timeout is 2 seconds:
Packet sent with a source address of FE80::2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

ΥڡΥȥåץ

Ф