カテゴリ

カテゴリ:Cisco

カテゴリ:

通常RIPはマルチキャストを利用してルーティング情報を流しますが、ユニキャストやブロードキャストを利用することも可能です。

R1(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.1      YES manual up                    up
Loopback0                  17.17.1.1       YES NVRAM  up                    up

R2(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.2      YES manual up                    up
Loopback0                  17.17.2.2       YES NVRAM  up                    up

R1とR2にRIPの設定を行います。

R1(config)#router rip
R1(config-router)#no auto-summary
R1(config-router)#version 2
R1(config-router)#network 12.12.12.1
R1(config-router)#network 17.17.1.1

設定後、デバグ画面を見るとマルチキャスト(224.0.0.9)を利用していることが確認できます。

R2(config-router)#do deb ip rip
RIP protocol debugging is on
Dec 11 05:54:42.151: RIP: received v2 update from 12.12.12.1 on FastEthernet0/0
Dec 11 05:54:42.151:      17.17.1.0/24 via 0.0.0.0 in 1 hops
Dec 11 05:54:52.475: RIP: sending v2 update to 224.0.0.9 via Loopback0 (17.17.2.2)
Dec 11 05:54:52.479: RIP: build update entries
Dec 11 05:54:52.479:    12.12.12.0/24 via 0.0.0.0, metric 1, tag 0
Dec 11 05:54:52.483:    17.17.1.0/24 via 0.0.0.0, metric 2, tag 0

ユニキャストを利用するにはまず、passive-interfaceコマンドでRIPの送信を止めます。そしてneighborコマンドで隣接ルータを指定します。

R1(config-router)#passive-interface f0/0
R1(config-router)#neighbor 12.12.12.2

デバグを確認するとユニキャスト(12.12.12.1)に変更されたことが確認できます。

Dec 11 05:57:46.843: RIP: received v2 update from 12.12.12.1 on FastEthernet0/0
Dec 11 05:57:46.843:      17.17.1.0/24 via 0.0.0.0 in 1 hops
Dec 11 05:58:05.067: RIP: sending v2 update to 12.12.12.1 via FastEthernet0/0 (12.12.12.2)
Dec 11 05:58:05.067: RIP: build update entries

最後にブロードキャストを確認します。まず先ほどのユニキャストの設定を解除します。

R1(config-router)#no passive-interface f0/0
R1(config-router)#no neighbor 12.12.12.2

設定はインターフェース上で行い、ip rip v2-broadcastコマンドを利用します。

R1(config-router)#int f0/0
R1(config-if)#ip rip v2-broadcast

すると、確かにブロードキャスト(255.255.255.255)が利用されることが分かります。

Dec 11 06:00:53.591: RIP: sending v2 update to 255.255.255.255 via FastEthernet0/0 (12.12.12.2)
Dec 11 06:00:53.595: RIP: build update entries
R2(config-router)#do und all
R2(config-router)#do deb ip pac de
IP packet debugging is on (detailed)
R2(config-router)#
Dec 11 06:20:10.495: IP: s=12.12.12.1 (FastEthernet0/0), d=255.255.255.255, len 52, rcvd 2
Dec 11 06:20:10.499:     UDP src=520, dst=520

カテゴリ:

Ciscoルータを利用中、Linuxでよく使うnetstatはないんだっけと思うことがよくあります。そんな時にshow tcpコマンドは近い感じです。

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.1      YES manual up                    up
Loopback0                  17.17.1.1       YES NVRAM  up                    up

R2#sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.2      YES manual up                    up
Loopback0                  17.17.2.2       YES NVRAM  up                    up

R1とR2があり、R1からR2に対してtelnet接続を行います。

R1#telnet 12.12.12.2
Trying 12.12.12.2 ... Open

User Access Verification

Password:
R2>

接続が完了したら、show tcp briefコマンドを実行してみます。netstat -tみたいな感じですね。

R2#show tcp brief
TCB       Local Address               Foreign Address             (state)
6738A76C  12.12.12.2.23               12.12.12.1.27603            ESTAB

ここに表示されるTCB(Transmission Control Block)を指定すると詳細の表示となります。

R2#show tcp tcb 6738A76C
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 12.12.12.2, Local port: 23
Foreign host: 12.12.12.1, Foreign port: 27603
Connection tableid (VRF): 0

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x1DFDC0):
Timer          Starts    Wakeups            Next
Retrans            75          0             0x0
TimeWait            0          0             0x0
AckHold            76          4             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss:  732715540  snduna:  732720033  sndnxt:  732720033     sndwnd:   3023
irs:  636591890  rcvnxt:  636592009  rcvwnd:       4010  delrcvwnd:    118

SRTT: 300 ms, RTTO: 303 ms, RTV: 3 ms, KRTT: 0 ms
minRTT: 12 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, active open
Option Flags: 0x400000
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 135 (out of order: 0), with data: 80, total data bytes: 118
Sent: 103 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 98, total data bytes: 4492
Packets received in fast path: 0, fast processed: 0, slow path: 0
Packets send in fast path: 0
fast lock acquisition failures: 0, slow path: 0

show tcp statisticsというコマンドもあります。

R2#show tcp statistics
Rcvd: 217 Total, 0 no port
      0 checksum error, 0 bad offset, 0 too short
      133 packets (246 bytes) in sequence
      0 dup packets (0 bytes)
      0 partially dup packets (0 bytes)
      0 out-of-order packets (0 bytes)
      0 packets (0 bytes) with data after window
      0 packets after close
      0 window probe packets, 2 window update packets
      3 dup ack packets, 0 ack packets with unsend data
      112 ack packets (4973 bytes)
Sent: 166 Total, 0 urgent packets
      7 control packets (including 0 retransmitted)
      142 data packets (4966 bytes)
      0 data packets (0 bytes) retransmitted
      0 data packets (0 bytes) fastretransmitted
      17 ack only packets (14 delayed)
      0 window probe packets, 0 window update packets
0 Connections initiated, 4 connections accepted, 4 connections established
3 Connections closed (including 0 dropped, 0 embryonic dropped)
0 Total rxmt timeout, 0 connections dropped in rxmt timeout
0 Keepalive timeout, 0 keepalive probe, 0 Connections dropped in keepalive

カテゴリ:

IOSで定期的にコマンドを実行するにはkronコマンドを利用します。UNIX/Linuxではcronですので注意して下さい。

まず実行するコマンドを定義します。kron policy-listコマンドに続いて登録するポリシー名を指定します。ここではF0/0_statusとしました。

R1(config)#kron policy-list F0/0_status

cliコマンドに続いて、実行したいコマンドを定義します。一度実行したものをコピーして使うと設定しやすいでしょう。ここで実行しているのはインターフェースF0/0の設定です。リダイレクトを使い、flashに保存しています。

R1(config-kron-policy)# cli show running-config interface f0/0 | redirect flash:f0status

このコマンドを直接実行すると下記のように表示されます。

R1(config)#do sh run int f0/0
Building configuration...

Current configuration : 94 bytes
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
speed 100
full-duplex
end

続いて、いつ実行するかを指定します。kron occurrenceコマンドに続き、登録名を指定します。先ほどのポリシー名とは別ですので注意が必要です。ここではMYKRONとしました。

時刻で指定する場合はatを利用します。hh:mmの形式で指定します。

R1(config)#kron occurrence MYKRON at ?
  hh:mm  Time of day for occurrence (hh:min eg. 14:30)

その後に月日や曜日が選べますが、毎日の実行であればここでrecurringを指定します。

R1(config)#kron occurrence MYKRON at 20:32 ?
  <1-31>     Day of month
  DAY        Day of Week eg mon, tue, etc
  MONTH      Month of year eg jan, feb, etc
  oneshot    Schedule kron occurrence exactly once
  recurring  Schedule kron occurrence repeatedly
  <cr>

R1(config)#kron occurrence MYKRON at 20:32 recurring

続いて実行するコマンドをポリシー名で指定します。

R1(config-kron-occurrence)# policy-list F0/0_status

設定の確認はsh kron scheduleを利用します。

R1#sh kron schedule
Kron Occurrence Schedule
MYKRON inactive, will run again in 0 days 00:03:45 at 20:32 on

指定時刻を過ぎてflashの中を確認するとファイルが確認できます。

R1(config)#do sh flash

System CompactFlash directory:
File  Length   Name/status
  1   142      f0status
[2028 bytes used, 16775184 available, 16777212 total]
16384K bytes of ATA System CompactFlash (Read/Write)

確かに自動的に実行されたようです。

R1(config)#do more flash:f0status
Building configuration...

Current configuration : 94 bytes
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
speed 100
full-duplex
end

CCIE Nightに参加

カテゴリ:

Img_2906今夜、初めてCCIE Nightに参加しました。久しぶりの方や、ブログやTwitterで知っている方に直接会って話しが出来て大変有意義な時間でした。

驚いたのは何人もの人にブログ読んでます、と言われたこと。嬉しいやらこっ恥ずかしいやら。顔写真を出しているといいこともありますね。

ちなみに若い女性のCCIEホルダーもいることが分かり、驚きました…。

カテゴリ:

前回のHSRPを続いてVRRP(Virtual Router Redundancy Protocol)の設定を行います。R1, R2, R4はそれぞれF0/0で124.124.124.0/24のネットワークで接続されています。R1はR3にシリアルケーブルで直結(13.13.13.0/24)、R2もR3にシリアルケーブルで直結(23.23.23.0/24)しています。

R1(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            124.124.124.1   YES manual up                    up
Serial1/2                  13.13.13.1      YES manual up                    up
Loopback0                  17.17.1.1       YES NVRAM  up                    up

R2(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            124.124.124.2   YES manual up                    up
Serial1/2                  23.23.23.2      YES manual up                    up
Loopback0                  17.17.2.2       YES NVRAM  up                    up

R3(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/2                  13.13.13.3      YES manual up                    up
Serial1/3                  23.23.23.3      YES manual up                    up
Loopback0                  17.17.3.3       YES NVRAM  up                    up

R4(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            124.124.124.4   YES manual up                    up
Loopback0                  17.17.4.4       YES NVRAM  up                    up

R1, R2, R3では全てのインターフェースでEIGRPを有効にします。

R3(config)#router ei 100
R3(config-router)#no au
R3(config-router)#net 0.0.0.0
R3(config)#do sh ip rou ei
     17.0.0.0/24 is subnetted, 3 subnets
D       17.17.1.0 [90/2297856] via 13.13.13.1, 00:07:11, Serial1/2
D       17.17.2.0 [90/2297856] via 23.23.23.2, 00:07:11, Serial1/3
     124.0.0.0/24 is subnetted, 1 subnets
D       124.124.124.0 [90/2172416] via 23.23.23.2, 00:07:11, Serial1/3
                      [90/2172416] via 13.13.13.1, 00:07:11, Serial1/2

R1とR2のF0/0にVRRPを設定します。vrrpコマンドを利用して設定しますが、ここではグループ番号を124としています。また割り当てる仮想のIPアドレスは124.124.124.254とします。R1を優先的に利用するためプライオリティを110としました(指定しない場合は100)。

R1(config-router)#int f0/0
R1(config-if)#vrrp ?
  <1-255>  Group number

R1(config-if)#vrrp 124 ?
  authentication  Authentication
  description     Group specific description
  ip              Enable Virtual Router Redundancy Protocol (VRRP) for IP
  preempt         Enable preemption of lower priority Master
  priority        Priority of this VRRP group
  shutdown        Disable VRRP Configuration
  timers          Set the VRRP timers
  track           Event Tracking

R1(config-if)#vrrp 124 ip 124.124.124.254
R1(config-if)#vrrp 124 priority 110
R1(config-if)#do sh vrrp

R2(config-router)#int f0/0
R2(config-if)#vrr
R2(config-if)#vrrp 124 ip 124.124.124.254

設定を確認します。R1がMasterとなり、有効であることが分かります。

FastEthernet0/0 - Group 124
  State is Master 
  Virtual IP address is 124.124.124.254
  Virtual MAC address is 0000.5e00.017c
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 110
  Master Router is 124.124.124.1 (local), priority is 110
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.570 sec

R2(config-if)#do sh vrrp
FastEthernet0/0 - Group 124
  State is Backup 
  Virtual IP address is 124.124.124.254
  Virtual MAC address is 0000.5e00.017c
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 100
  Master Router is 124.124.124.1, priority is 110
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.609 sec (expires in 2.905 sec)

R4より124.124.124.254へのpingが実行できることを確認しています。

R4(config)#do pin 124.124.124.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 124.124.124.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/13/36 ms
R4(config)#do sh ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  124.124.124.254         0   0000.5e00.017c  ARPA   FastEthernet0/0

R4にデフォルトゲートウェイを124.124.124.254で設定します。

R4(config)#ip route 0.0.0.0 0.0.0.0 124.124.124.254
R4(config)#do sh ip rou sta
S*   0.0.0.0/0 [1/0] via 124.124.124.254

設定後、R3へのLo0へpingが実行できることが分かり、tracerouteコマンドでR1を経由していることも確認できます。

R4(config)#do trace 17.17.3.3

Type escape sequence to abort.
Tracing the route to 17.17.3.3

  1 124.124.124.1 4 msec 8 msec 8 msec
  2 13.13.13.3 16 msec *  24 msec

ここでR2でデバグを有効し、R1のF0/0をシャットします。

R2(config)#do deb vrrp
VRRP debugging is on

Nov 15 06:10:37.339: VRRP: Grp 124 Advertisement priority 0, ipaddr 124.124.124.1
Nov 15 06:10:37.343: VRRP: Grp 124 Event - Advert priority 0
Nov 15 06:10:37.959: VRRP: Grp 124 Event - Master down timer expired
Nov 15 06:10:37.963: %VRRP-6-STATECHANGE: Fa0/0 Grp 124 state Backup -> Master

R1のF0/0が使用不可能になると自動的にR2のF0/0を経由することがtracerouteコマンドで確認出来ます。

R4(config)#do trace 17.17.3.3

Type escape sequence to abort.
Tracing the route to 17.17.3.3

  1 124.124.124.2 8 msec 12 msec 4 msec
  2 23.23.23.3 8 msec *  16 msec

カテゴリ:

今回はHSRP(Hot Standby Routing Protocol)の設定を行います。R1, R2, R4はそれぞれF0/0で124.124.124.0/24のネットワークで接続されています。R1はR3にシリアルケーブルで直結(13.13.13.0/24)、R2もR3にシリアルケーブルで直結(23.23.23.0/24)しています。

R1(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            124.124.124.1   YES manual up                    up
Serial1/2                  13.13.13.1      YES manual up                    up
Loopback0                  17.17.1.1       YES NVRAM  up                    up

R2(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            124.124.124.2   YES manual up                    up
Serial1/2                  23.23.23.2      YES manual up                    up
Loopback0                  17.17.2.2       YES NVRAM  up                    up

R3(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/2                  13.13.13.3      YES manual up                    up
Serial1/3                  23.23.23.3      YES manual up                    up
Loopback0                  17.17.3.3       YES NVRAM  up                    up

R4(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            124.124.124.4   YES manual up                    up
Loopback0                  17.17.4.4       YES NVRAM  up                    up

R1, R2, R3では全てのインターフェースでEIGRPを有効にします。

R3(config)#router ei 100
R3(config-router)#no au
R3(config-router)#net 0.0.0.0
R3(config)#do sh ip rou ei
     17.0.0.0/24 is subnetted, 3 subnets
D       17.17.1.0 [90/2297856] via 13.13.13.1, 00:07:11, Serial1/2
D       17.17.2.0 [90/2297856] via 23.23.23.2, 00:07:11, Serial1/3
     124.0.0.0/24 is subnetted, 1 subnets
D       124.124.124.0 [90/2172416] via 23.23.23.2, 00:07:11, Serial1/3
                      [90/2172416] via 13.13.13.1, 00:07:11, Serial1/2

まずR4からpingコマンドを実行して、接続を確認します。

R4(config)#do pin 124.124.124.1
R4(config)#do pin 124.124.124.2

ではR1とR2のF0/0にHSRPを設定します。standbyコマンドを利用して設定しますが、ここではグループ番号を124としています。また割り当てる仮想のIPアドレスは124.124.124.254とします。R1を優先的に利用するためプライオリティを110としました(指定しない場合は100)。

R1(config)#int f0/0
R1(config-if)#standby 124 ip 124.124.124.254
R1(config-if)#standby 124 priority 110

R2(config)#int f0/0
R2(config-if)#standby 124 ip 124.124.124.254

設定を確認します。R1がActiveとなり、有効であることが分かります。

R1(config-if)#do sh standby
FastEthernet0/0 - Group 124
  State is Active
    2 state changes, last state change 00:07:41
  Virtual IP address is 124.124.124.254
  Active virtual MAC address is 0000.0c07.ac7c
    Local virtual MAC address is 0000.0c07.ac7c (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.756 secs
  Preemption disabled
  Active router is local
  Standby router is 124.124.124.2, priority 100 (expires in 9.640 sec)
  Priority 110 (configured 110)
  Group name is "hsrp-Fa0/0-124" (default)

R2(config-if)#do sh standby
FastEthernet0/0 - Group 124
  State is Listen
  Virtual IP address is 124.124.124.254
  Active virtual MAC address is 0000.0c07.ac7c
    Local virtual MAC address is 0000.0c07.ac7c (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption disabled
  Active router is 124.124.124.1, priority 110 (expires in 7.148 sec)
  Standby router is unknown
  Priority 100 (default 100)
  Group name is "hsrp-Fa0/0-124" (default)

R4より124.124.124.254へのpingが実行できることを確認しています。

R4(config)#do pin 124.124.124.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 124.124.124.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/7/8 ms
R4(config)#do sh ip arp 124.124.124.254
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  124.124.124.254         0   0000.0c07.ac7c  ARPA   FastEthernet0/0

R4にデフォルトゲートウェイを124.124.124.254で設定します。

R4(config)#ip route 0.0.0.0 0.0.0.0 124.124.124.254
R4(config)#do sh ip rou sta
S*   0.0.0.0/0 [1/0] via 124.124.124.254

設定後、R3へのLo0へpingが実行できることが分かり、tracerouteコマンドでR1を経由していることも確認できます。

R4(config)#do pin 17.17.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 17.17.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms
R4(config)#do trace 17.17.3.3

Type escape sequence to abort.
Tracing the route to 17.17.3.3

  1 124.124.124.1 8 msec 8 msec 8 msec
  2 13.13.13.3 8 msec *  32 msec

ここでR2でデバグを有効し、R1のF0/0をシャットします。

R2(config)#do deb standby
HSRP debugging is on

R1(config-if)#sh
Nov  7 06:19:25.235: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 124 state Active -> Init

Nov  7 06:19:22.715: HSRP: Fa0/0 Grp 124 Active router is local, was 124.124.124.1
Nov  7 06:19:22.719: HSRP: Fa0/0 Nbr 124.124.124.1 no longer active for group 124 (Standby)
Nov  7 06:19:22.723: HSRP: Fa0/0 Nbr 124.124.124.1 Was active or standby - start passive holddown
Nov  7 06:19:22.723: HSRP: Fa0/0 Grp 124 Standby router is unknown, was local
Nov  7 06:19:22.727: HSRP: Fa0/0 Grp 124 Standby -> Active
Nov  7 06:19:22.731: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 124 state Standby -> Active

R1のF0/0が使用不可能になると自動的にR2のF0/0を経由することがtracerouteコマンドで確認出来ます。

R4(config)#do trace 17.17.3.3

Type escape sequence to abort.
Tracing the route to 17.17.3.3

  1 124.124.124.2 8 msec 8 msec 8 msec
  2 23.23.23.3 12 msec *  8 msec

カテゴリ:

今回はDHCPサーバを異なるネットワークに置いた場合の設定を確認します。ip helper-addressコマンドを使いますが、どこにコマンドを適用するのか、慣れないと迷います。

R2はR1(F0/0)とR3(S1/3)にそれぞれ直結しています。ここではR3をDHCPサーバとし、R1のインターフェースをDHCPクライアントとします。

R2(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.2      YES manual up                    up
Serial1/2                  23.23.23.2      YES manual up                    up
Loopback0                  17.17.2.2       YES NVRAM  up                    up

R3(config)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
Serial1/3                  23.23.23.3      YES manual up                    up
Loopback0                  17.17.3.3       YES NVRAM  up                    up

まず前回を参考にR3にDHCPサーバの設定を行います。

R3(config)#ip dhcp pool MYDHCP

R3(dhcp-config)#network 12.12.12.0 /24
R3(dhcp-config)#exit
R3(config)#ip dhcp excluded-address 12.12.12.0 12.12.12.99
R3(config)#do deb ip dhcp server event
R3(config)#do sh ip dhcp pool MYDHCP

Pool MYDHCP :
Utilization mark (high/low)    : 100 / 0
Subnet size (first/next)       : 0 / 0
Total addresses                : 254
Leased addresses               : 0
Pending event                  : none
1 subnet is currently in the pool :
Current index        IP address range                    Leased addresses
12.12.12.1           12.12.12.1       - 12.12.12.254      0

ここでR1のF0/0でDHCPを有効にします。

R1(config)#int f0/0
R1(config-if)#ip address dhcp
R1(config-if)#no sh

有効にしてもDHCPによるIPアドレスの割り当ては行われません。これは23.23.23.0/24にあるDHCPサーバまでBOOTPパケットが転送されないからです。

R1(config-if)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES DHCP   up                    up

BOOTPパケットの転送を行うためにip helper-addressコマンドを利用しますが、設定するのはBOOTPパケットを受け取るインターフェースになります(この場合、R1のF0/0に直結しているR2のF0/0)。

R2(config)#int f0/0
R2(config-if)#ip helper-address 23.23.23.3
R2(config-if)#do sh ip int f0/0 | i Help
  Helper address is 23.23.23.3

設定後、しばらくするとR3に反応が出ます。

Oct 30 06:21:54.383: DHCPD: Adding binding to radix tree (12.12.12.100)
Oct 30 06:21:54.383: DHCPD: Adding binding to hash tree
Oct 30 06:21:54.387: DHCPD: assigned IP address 12.12.12.100 to client 0063.6973.636f.2d63.3230.302e.3165.3633.2e30.3030.302d.4661.302f.30.
Oct 30 06:21:54.427: DHCPD: Sending notification of ASSIGNMENT:
Oct 30 06:21:54.427:  DHCPD: address 12.12.12.100 mask 255.255.255.0

R3(config)#do sh ip dhcp bind
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
12.12.12.100        0063.6973.636f.2d63.    Oct 31 2011 03:21 PM    Automatic
                    3230.302e.3165.3633.
                    2e30.3030.302d.4661.
                    302f.30

R1で正しくIPアドレスが割り当てられたことが分かります。

R1(config-if)#
Oct 30 06:21:51.911: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address 12.12.12.100, mask 255.255.255.0, hostname R1

R1(config-if)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.100    YES DHCP   up                    up

カテゴリ:

今回はDHCPサーバの設定を行います。それほど難しい点はありませんが、独特な設定箇所があります。

まずip dhcp poolコマンドで利用するDHCP名を定義します、ここではMYDHCPとしました。

R2(config)#ip dhcp pool MYDHCP

次に利用するネットワークを指定します。ここでは12.12.12.0/24を指定しますが、マスク値の前にはスペースが必要です。

R2(dhcp-config)#network 12.12.12.0 ?
  /nn or A.B.C.D  Network mask or prefix length
  <cr>

R2(dhcp-config)#network 12.12.12.0 /24

デフォルトゲートウェイを指定するにはdefault-routerを利用します。

R2(dhcp-config)#default-router 12.12.12.2

リース期間はleaseコマンドを使い、続けて日数、時間数を指定します。下記は8時間を指定した例です。

R2(dhcp-config)#lease 0 8

DHCPサーバを定義する時に貸し出すIPアドレスの範囲を指定します。利用するのはip dhcp excluded-addressコマンドです。名前の通り貸し出さないIPアドレスを指定します。ここでは12.12.12.100から12.12.12.199までを貸し出す範囲とします。

R2(config)#ip dhcp excluded-address 12.12.12.0 12.12.12.99
R2(config)#ip dhcp excluded-address 12.12.12.200 12.12.12.255

これで準備は完了です。sh ip dhcp poolコマンドで設定を確認できますが、ここにはexcludedアドレスは表示されません。

R2#sh ip dhcp pool MYDHCP

Pool MYDHCP :
Utilization mark (high/low)    : 100 / 0
Subnet size (first/next)       : 0 / 0
Total addresses                : 254
Leased addresses               : 1
Pending event                  : none
1 subnet is currently in the pool :
Current index        IP address range                    Leased addresses
12.12.12.101         12.12.12.1       - 12.12.12.254      1

デバグを有効にしてDHCPクライアントを設定します。

R2#debug ip dhcp server events

直接R2に接続されているR1のインターフェース(f0/0)にDHCPを設定し、no shutします。

R2(config-if)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.2      YES manual up                    up
Loopback0                  17.17.2.2       YES NVRAM  up                    up

R1(config)#int f0/0
R1(config-if)#ip address dhcp
R1(config-if)#no shutdown

R2のデバグが表示され、IPアドレスが提供されます。

R2(config-if)#
Oct 24 06:02:53.851: DHCPD: assigned IP address 12.12.12.100 to client 0063.6973.636f.2d63.3230.302e.3132.3161.2e30.3030.302d.4661.302f.30.
Oct 24 06:02:53.863: DHCPD: Sending notification of ASSIGNMENT:
Oct 24 06:02:53.863:  DHCPD: address 12.12.12.100 mask 255.255.255.0
Oct 24 06:02:53.863:   DHCPD: htype 1 chaddr c200.121a.0000
Oct 24 06:02:53.863:   DHCPD: lease time remaining (secs) = 28800

貸し出しているIPアドレスを確認するにはshow ip dhcp bindingコマンドを利用します。

R2#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
12.12.12.100        0063.6973.636f.2d63.    Oct 24 2011 11:02 PM    Automatic
                    3230.302e.3132.3161.
                    2e30.3030.302d.4661.
                    302f.30

R1でインターフェースを確認しています。

R1(config-if)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.100    YES DHCP   up                    up

デフォルトゲートウェイを受け取っていることも分かります。

R1(config)#do sh ip rou static
S*   0.0.0.0/0 [254/0] via 12.12.12.2

カテゴリ:

Linuxでは/etc/hostsにホスト名を登録することで、任意の名前でアクセスが可能になります。下記は192.168.0.1をrouter1で登録する例で、設定後はrouter1でpingコマンドが実行できることが分かります。

# ping router1
ping: unknown host router1
# vi /etc/hosts
# tail -1 /etc/hosts
192.168.0.1           router1.tempest.jp router1
# ping router1
PING router1.tempest.jp (192.168.0.1) 56(84) bytes of data.
64 bytes from router1.tempest.jp (192.168.0.1): icmp_seq=1 ttl=64 time=0.875 ms
〜略〜

IOSでのホスト名の指定にはip hostコマンドを利用します。

R2(config)#do ping R1

Translating "R1"
% Unrecognized host or address, or protocol not running.

R2(config)#ip host R1 17.17.1.1
R2(config)#do pin R1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 17.17.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/12 ms

設定の確認にはshow hostコマンドを利用します。通常使うルータやサーバを登録しておくと接続が楽になります。

R2(config)#do sh host
Default domain is not set
Name/address lookup uses static mappings

Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate
       temp - temporary, perm - permanent
       NA - Not Applicable None - Not defined

Host                      Port  Flags      Age Type   Address(es)
R1                        None  (perm, OK)  0   IP    17.17.1.1

同じホスト名で登録すると上書きとなりますので注意が必要です。

R2(config)#ip host R1 12.12.12.1
R2(config)#do sh host
〜略〜
R1                        None  (perm, OK)  0   IP    12.12.12.1

個別に解除するにはno ip hostコマンドを実行します。

R2(config)#no ip host R1 12.12.12.1

カテゴリ:

今回は前回のmenuコマンドの設定をもう少し詳しく確認します。まず前回はタイトルのみを指定しましたが、併せてpromptを利用すると便利でしょう。実行時に、入力する文字の前に表示(今回はchoose one:)されます。

R1(config)#menu MYMENU title -
Enter TEXT message.  End with the character '-'.
This is my menu
-

R1(config)#R1(config)#menu MYMENU prompt - choose one: -

各menuの指定時に、オプションでpauseを指定することが出来ます。ここでは1番と2番に同じshow clockを指定し、2番にのみpauseを設定しました。

R1(config)#menu MYMENU text 1. show clock
R1(config)#menu MYMENU command 1. show clock
R1(config)#menu MYMENU text 2. show clock
R1(config)#menu MYMENU command 2. show clock
R1(config)#menu MYMENU options 2. pause
R1(config)#menu MYMENU text 3. exit
R1(config)#menu MYMENU command 3. exit

実行して違いを確認します。直接menuコマンドを実行することで利用が開始されます。

R1(config)#do menu MYMENU

This is my menu

    1.         show clock

    2.         show clock

    3.         exit

Choose one: ← 1を入力
16:13:41.491 JST Tue Oct 11 2011
This is my menu

    1.         show clock

    2.         show clock

    3.         exit

Choose one: ← 2を入力
16:13:42.975 JST Tue Oct 11 2011
--More--

2を入力した後は、何かキーを打つまで画面が保留状態に留まることが分かります。

今確認したように、初期値では入力したキーは表示されません。確認して実行するにはline-modeを利用します。

R1(config)#menu MYMENU ?
〜略〜
  line-mode     require <enter> after typing selection
〜略〜
R1(config)#menu MYMENU line-mode

設定後に再実行すると番号が表示され、enterキーで有効になることが分かります。

R1(config)#do menu MYMENU
〜略〜
    3.         exit

Choose one: 1
16:20:25.095 JST Tue Oct 11 2011

defaultを指定すると、選択しない場合の実行を指定できます。ここでは1番をdefaultとしました。選択せずに、enterのみを押すと1番のshow clockが実行されることが分かります。

R1(config)#menu MYMENU default 1
R1(config)#menu MYMENU ?
〜略〜
Choose one:
16:22:09.495 JST Tue Oct 11 2011

menuを解除するにはno menuを実行します。

R1(config)#no menu MYMENU

このページのトップヘ

見出し画像
×