2011ǯ10

ƥ:

DHCPФԤޤۤ񤷤Ϥޤ󤬡äս꤬ޤ

ޤip dhcp poolޥɤѤDHCP̾ޤǤMYDHCPȤޤ

R2(config)#ip dhcp pool MYDHCP

ѤͥåȥꤷޤǤ12.12.12.0/24ꤷޤޥͤˤڡɬפǤ

R2(dhcp-config)#network 12.12.12.0 ?
  /nn or A.B.C.D  Network mask or prefix length
  <cr>

R2(dhcp-config)#network 12.12.12.0 /24

ǥեȥȥꤹˤdefault-routerѤޤ

R2(dhcp-config)#default-router 12.12.12.2

꡼֤leaseޥɤȤ³ֿꤷޤ8֤ꤷǤ

R2(dhcp-config)#lease 0 8

DHCPФߤФIPɥ쥹ϰϤꤷޤѤΤip dhcp excluded-addressޥɤǤ̤̾ߤФʤIPɥ쥹ꤷޤǤ12.12.12.10012.12.12.199ޤǤߤФϰϤȤޤ

R2(config)#ip dhcp excluded-address 12.12.12.0 12.12.12.99
R2(config)#ip dhcp excluded-address 12.12.12.200 12.12.12.255

ǽϴλǤsh ip dhcp poolޥɤǧǤޤˤexcludedɥ쥹ɽޤ

R2#sh ip dhcp pool MYDHCP

Pool MYDHCP :
Utilization mark (high/low)    : 100 / 0
Subnet size (first/next)       : 0 / 0
Total addresses                : 254
Leased addresses               : 1
Pending event                  : none
1 subnet is currently in the pool :
Current index        IP address range                    Leased addresses
12.12.12.101         12.12.12.1       - 12.12.12.254      1

ǥХͭˤDHCP饤Ȥꤷޤ

R2#debug ip dhcp server events

ľR2³ƤR1Υ󥿡ե(f0/0)DHCPꤷno shutޤ

R2(config-if)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.2      YES manual up                    up
Loopback0                  17.17.2.2       YES NVRAM  up                    up

R1(config)#int f0/0
R1(config-if)#ip address dhcp
R1(config-if)#no shutdown

R2ΥǥХɽ졢IPɥ쥹󶡤ޤ

R2(config-if)#
Oct 24 06:02:53.851: DHCPD: assigned IP address 12.12.12.100 to client 0063.6973.636f.2d63.3230.302e.3132.3161.2e30.3030.302d.4661.302f.30.
Oct 24 06:02:53.863: DHCPD: Sending notification of ASSIGNMENT:
Oct 24 06:02:53.863:  DHCPD: address 12.12.12.100 mask 255.255.255.0
Oct 24 06:02:53.863:   DHCPD: htype 1 chaddr c200.121a.0000
Oct 24 06:02:53.863:   DHCPD: lease time remaining (secs) = 28800

ߤФƤIPɥ쥹ǧˤshow ip dhcp bindingޥɤѤޤ

R2#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
12.12.12.100        0063.6973.636f.2d63.    Oct 24 2011 11:02 PM    Automatic
                    3230.302e.3132.3161.
                    2e30.3030.302d.4661.
                    302f.30

R1ǥ󥿡եǧƤޤ

R1(config-if)#do sh ip int b
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.100    YES DHCP   up                    up

ǥեȥȥäƤ뤳Ȥʬޤ

R1(config)#do sh ip rou static
S*   0.0.0.0/0 [254/0] via 12.12.12.2

SiriȤäƤߤ 2

ƥ:

Siri2ʤʤȤʹƤʤiPhone 4SSiriǤȯγǧˤϤˡޤ

"What's the phone number of me"Ǽʬֹ椬ФϤǤѤơȯǧ桼̾ϿФΤǤϡġ

Τ褦˥եȥ͡John(̣Ϥޤ)ǥ饹ȥ͡ȯ񤷤ʤΤƤߤޤ

ޤܿͤˤϤ«RLΰ㤤RightLightǡTHThinkSink󡣺ǸˤʤǧƤʤ"What's the weather for today."ΤWeather

ͥƥ֥ԡä顢5ͤȯǸʬΤʤ

ƥ:

LinuxǤ/etc/hosts˥ۥ̾Ͽ뤳ȤǡǤդ̾ǥǽˤʤޤ192.168.0.1router1Ͽǡrouter1pingޥɤ¹ԤǤ뤳Ȥʬޤ

# ping router1
ping: unknown host router1
# vi /etc/hosts
# tail -1 /etc/hosts
192.168.0.1           router1.tempest.jp router1
# ping router1
PING router1.tempest.jp (192.168.0.1) 56(84) bytes of data.
64 bytes from router1.tempest.jp (192.168.0.1): icmp_seq=1 ttl=64 time=0.875 ms
ά

IOSǤΥۥ̾λˤip hostޥɤѤޤ

R2(config)#do ping R1

Translating "R1"
% Unrecognized host or address, or protocol not running.

R2(config)#ip host R1 17.17.1.1
R2(config)#do pin R1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 17.17.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/12 ms

γǧˤshow hostޥɤѤޤ̾Ȥ롼䥵ФϿƤ³ڤˤʤޤ

R2(config)#do sh host
Default domain is not set
Name/address lookup uses static mappings

Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate
       temp - temporary, perm - permanent
       NA - Not Applicable None - Not defined

Host                      Port  Flags      Age Type   Address(es)
R1                        None  (perm, OK)  0   IP    17.17.1.1

Ʊۥ̾ϿȾ񤭤ȤʤޤΤդɬפǤ

R2(config)#ip host R1 12.12.12.1
R2(config)#do sh host
ά
R1                        None  (perm, OK)  0   IP    12.12.12.1

̤˲ˤno ip hostޥɤ¹Ԥޤ

R2(config)#no ip host R1 12.12.12.1

SiriȤäƤߤ 1

ƥ:

Siri iPhone 4SϤΤǡ®ԤSiriƤߤƥθ꤬ܸǤѤʤۡܥĹΤ򼪤ˤƤSiriư롣

Ȥꤢ"Send message to my wife."ĩ魯⡢줬ѡޤ"my wife""my life"ǧ㤦ġ̤˹ͤ"life"ȯä񤷤ϤʤΤˡ

Ȥ"my wife"̤ȼï"wife"ꤷȤʤ롣Ƭǡֹ椫᡼륢ɥ쥹ꤹȤ򤵡ơ"123"ȤñֹŪϿ뤳ȤDz褷

Ȥθ塢Ϣ˴طԤȤܤƤꡢʬΥڡ۶ԤϿФȤʬä"my mom"Ǥ"my mother"ǤƤӽФ롣

ʤߤ˾嵭̤Send򲡤yesƤ뤳ȤǽʤߤCancelϲٸäƤ̤ʤ!!

ȤȤSiriȤ襤³

ƥ:

menuޥɤ⤦ܤǧޤޤϥȥΤߤꤷޤʻpromptѤǤ礦¹ԻˡϤʸɽ(choose one:)ޤ

R1(config)#menu MYMENU title -
Enter TEXT message.  End with the character '-'.
This is my menu
-

R1(config)#R1(config)#menu MYMENU prompt - choose one: -

menuλˡץpauseꤹ뤳ȤޤǤ1֤2֤Ʊshow clockꤷ2֤ˤΤpauseꤷޤ

R1(config)#menu MYMENU text 1. show clock
R1(config)#menu MYMENU command 1. show clock
R1(config)#menu MYMENU text 2. show clock
R1(config)#menu MYMENU command 2. show clock
R1(config)#menu MYMENU options 2. pause
R1(config)#menu MYMENU text 3. exit
R1(config)#menu MYMENU command 3. exit

¹Ԥư㤤ǧޤľmenuޥɤ¹Ԥ뤳ȤѤϤޤ

R1(config)#do menu MYMENU

This is my menu

    1.         show clock

    2.         show clock

    3.         exit

Choose one: 1
16:13:41.491 JST Tue Oct 11 2011
This is my menu

    1.         show clock

    2.         show clock

    3.         exit

Choose one: 2
16:13:42.975 JST Tue Oct 11 2011
--More--

2ϤϡǤĤޤDz̤α֤αޤ뤳Ȥʬޤ

ǧ褦ˡͤǤϤɽޤ󡣳ǧƼ¹Ԥˤline-modeѤޤ

R1(config)#menu MYMENU ?
ά
  line-mode     require <enter> after typing selection
ά
R1(config)#menu MYMENU line-mode

˺Ƽ¹Ԥֹ椬ɽ졢enterͭˤʤ뤳Ȥʬޤ

R1(config)#do menu MYMENU
ά
    3.         exit

Choose one: 1
16:20:25.095 JST Tue Oct 11 2011

defaultꤹȡ򤷤ʤμ¹ԤǤޤǤ1֤defaultȤޤ򤻤ˡenterΤߤ򲡤1֤show clock¹Ԥ뤳Ȥʬޤ

R1(config)#menu MYMENU default 1
R1(config)#menu MYMENU ?
ά
Choose one:
16:22:09.495 JST Tue Oct 11 2011

menuˤno menu¹Ԥޤ

R1(config)#no menu MYMENU

ƥ:

ȤǤʤ꤬ʬŤ餤ΤmenuޥɤǤǤϤñ򤷤ˡǧޤ

R1Ԥޤޤmenuޥɤ³ơꤹ˥塼̾ꤷޤǤMYMENUȤޤʻƥ˥塼ΥȥꤷޤʬŤ餤Ǥ˻ȤäʸǺǸĤޤ

R1(config)#menu MYMENU title -
Enter TEXT message.  End with the character '-'.
This is my menu
-
R1(config)#

³Ƽºݤɽ˥塼ޤ1֤show ip route2֤show ip interface bried3֤exitꤷƤߤޤ

1֤ޤꤷޤtext³"1"Ϥθɽʸꤷޤ

R1(config)#menu MYMENU text ?
  WORD  Menu item number or character

R1(config)#menu MYMENU text 1 ?
  LINE  Text for this menu item

R1(config)#menu MYMENU text 1 show ip route

˼ºݤ˼¹Ԥ륳ޥɤꤷޤ

R1(config)#menu MYMENU command 1 ?
  LINE  Command for this menu item

R1(config)#menu MYMENU command 1 show ip route

μ2֤3֤ꤷޤ

R1(config)#menu MYMENU text 2 show ip interface brief
R1(config)#menu MYMENU command 2 show ip interface brief
R1(config)#menu MYMENU text 3 finish this menu
R1(config)#menu MYMENU command 3 exit

ꤵ줿˥塼TELNETǥ桼ciscoǥ󤷤˼¹ԤԤޤ

R1(config)#username cisco secret cisco
R1(config)#username cisco autocommand menu MYMENU
R1(config)#line vty 0 4
R1(config-line)#login local

TELNET³ȥ˥塼ɽ뤳Ȥʬޤ

R1(config-line)#do telnet 17.17.1.1
Trying 17.17.1.1 ... Open

User Access Verification

Username: cisco
Password:
This is my menu

    1          show ip route

    2          show ip interface brief

    3          finish this menu

ξ֤"1"򲡤ȲΤ褦ɽޤ

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     17.0.0.0/24 is subnetted, 2 subnets
C       17.17.1.0 is directly connected, Loopback0
D       17.17.2.0 [90/156160] via 12.12.12.2, 00:26:11, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
This is my menu

    1          show ip route

    2          show ip interface brief

    3          finish this menu

"2"򲡤ȲΤ褦ˤʤޤ

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.1      YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  unassigned      YES unset  administratively down down
Loopback0                  17.17.1.1       YES NVRAM  up                    up
This is my menu

    1          show ip route

    2          show ip interface brief

    3          finish this menu

Ǹ"3"ǽλȤʤޤ

[Connection to 17.17.1.1 closed by foreign host]

꤯Ѥн鿴Ԥ˴Ǥ뤳ȤǽˤʤǤ礦

ΥڡΥȥåץ

Ф