2011ǯ01

ɴǯθȡץ֥ꥨ롦륷ޥ륱

ƥ:

100Ƥβʤؤä褿䤬ƥޥɤȤĮˤʤꡢŴƻ̤ä褬ꡢĹ³ä

ͭ̾ʺʤǤäɤ⤦ȻפäƤʤʬܤʤΤǻ˹ʤɤ⤦ȤäȻפäƤ²100ǯˤϤԻ׵ĤäǤ⤫³

ɤǤƻΤоʪ̾Ʊ̾륫ǥ饢ΤͤФƤΤ纮𡣤ޤоʪǧʤɤܤϤĤƤʤ줫ɤΤǤСȷϿޤĤġ⤷ƤȤǤ礦ʤߤ˱ͺΡ֥ǥ纴ˤϰ㤦˻ޤ©ҡΤ17ͤޤġ

ɤ߽ȤʢäѤȤɡ⤦ɤߤ⤹롣ĤǯäƲˤˤʤä顢ɤ⤦ʡ֤ΤˤäɤܤõƤ˶ᡣ

ɴǯθ (Gabriel Jose Garcia Marquez (1967))

ƥ:

EIGRPꤹȤǤΤ褦꤬ƤꡢF0/0 S1/2 Lo0ȤIPɥ쥹ꤷƤ륤󥿡եƤEIGRPAS100ꤷƤޤ

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.2      YES manual up                    up      
FastEthernet0/1            unassigned      YES unset  administratively down down   
Serial1/0                  unassigned      YES unset  administratively down down   
Serial1/1                  unassigned      YES unset  administratively down down   
Serial1/2                  23.23.23.2      YES manual up                    up      
Serial1/3                  unassigned      YES unset  administratively down down   
Loopback0                  17.17.2.2       YES NVRAM  up                    up      

EIGRPAS100ǻꤷưޤʣASꤷEIGRPѤ뤳Ȥޤ1Ĥˤޤ

R2(config)#router eigrp 100

˥롼IDꤷޤɬܤǤϤޤ󤬡տޤʤIDˤʤ뤳Ȥ򤱤뤿ꤹ˾ޤǤ礦ǤLo0IPɥ쥹ѤƤޤ

R2(config-router)#eigrp router-id 17.17.2.2

networkޥɤѤ󥿡եꤷޤǤϥ磻ɥɤ0.0.0.0ȻꤷƤޤ

R2(config-router)#network 12.12.12.2 0.0.0.0
R2(config-router)#network 23.23.23.2 0.0.0.0
R2(config-router)#network 17.17.2.2 0.0.0.0

networkޥɤ󥿡եǤƤ뤫ǧˤshow ip eigrp interfacesѤޤ

R2#show ip eigrp interfaces
IP-EIGRP interfaces for process 100

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              1        0/0        13       0/1           50           0
Se1/2              1        0/0        10       0/15          50           0
Lo0                0        0/0         0       0/1            0           0

ꤷ󥿡ե³ǤEIGRPͭˤȡ˲Τ褦ʥɽ졢³줿ȤǧǤǤ礦EIGRP˹®³λΤħǤ

Jan 26 06:04:50.043: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 12.12.12.1 (FastEthernet0/0) is up: new adjacency
Jan 26 06:05:05.099: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 23.23.23.3 (Serial1/2) is up: new adjacency

ܥ롼Ȥ³ǧˤshow ip eigrp neighborsѤޤ

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   23.23.23.3              Se1/2             13 00:14:23   10   200  0  3
0   12.12.12.1              Fa0/0             12 00:14:38   13   200  0  4

EIGRPդ٤ϽͤǤϽ롼(auto-summary)ͭǤǤǧˤshow ip protocolsѤǤޤ

R2#show ip protocols | include Automatic network
  Automatic network summarization is in effect

롼ȤͭǤ븽ߤΥ롼ƥ󥰥ơ֥ϲΤ褦ˤʤäƤޤ󥿡եǤ/24ꤵƤͥåȥưŪ/8Ƚ󤵤Ƥ뤳Ȥʬޤ

R2#show ip route eigrp
     17.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       17.0.0.0/8 is a summary, 01:27:11, Null0
     23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       23.0.0.0/8 is a summary, 01:28:52, Null0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       12.0.0.0/8 is a summary, 01:28:52, Null0

롼Ȥ̵ˤˤno auto-summaryѤޤ

R2(config)#router eigrp 100
R2(config-router)#no auto-summary

R2#show ip protocols | include Automatic network
  Automatic network summarization is not in effect

ܤ롼Ǥno auto-summaryꤷθ롼ƥ󥰥ơ֥⤦ٳǧ17.0.0.0Υͥåȥ/24dzǧǤƤ뤳Ȥʬޤ

R2#show ip route eigrp
     17.0.0.0/24 is subnetted, 3 subnets
D       17.17.1.0 [90/156160] via 12.12.12.1, 00:14:51, FastEthernet0/0
D       17.17.3.0 [90/2297856] via 23.23.23.3, 00:14:53, Serial1/2

EIGRPǤΥȥݥɽˤshow ip eigrp topologyѤޤɽƤͥåȥꤹ뤳ȤǾܺ٤ǧ뤳ȤޤޤΥޥɤꤷRouter IDǧǤ뤳Ȥʬޤ

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(17.17.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 17.17.1.0/24, 1 successors, FD is 156160
        via 12.12.12.1 (156160/128256), FastEthernet0/0
P 17.17.2.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 17.17.3.0/24, 1 successors, FD is 2297856
        via 23.23.23.3 (2297856/128256), Serial1/2
P 12.12.12.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 23.23.23.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/2

R2#show ip eigrp topology 17.17.1.0/24
IP-EIGRP (AS 100): Topology entry for 17.17.1.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 156160
  Routing Descriptor Blocks:
  12.12.12.1 (FastEthernet0/0), from 12.12.12.1, Send flag is 0x0
      Composite metric is (156160/128256), Route is Internal
      Vector metric:
        Minimum bandwidth is 100000 Kbit
        Total delay is 5100 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

EIGRPƤΥ󥿡ͥåȤͭˤˤnetwork 0.0.0.0ѤޤȤꤢʣΥ롼֤ping̤褦ˤʤɤǤ

R2(config)#no router eigrp 100
R2(config)#router eigrp 100
R2(config-router)#no auto-summary
R2(config-router)#network 0.0.0.0

ƥ:

OSPF򤹤ǤΤ褦꤬ƤꡢF0/0 S1/2 Lo0ȤIPɥ쥹ꤷƤ륤󥿡եƤOSPFarea 0ꤷƤޤ

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.2      YES manual up                    up      
FastEthernet0/1            unassigned      YES unset  administratively down down   
Serial1/0                  unassigned      YES unset  administratively down down   
Serial1/1                  unassigned      YES unset  administratively down down   
Serial1/2                  23.23.23.2      YES manual up                    up      
Serial1/3                  unassigned      YES unset  administratively down down   
Loopback0                  17.17.2.2       YES NVRAM  up                    up      

ǤOSPFץID 1ǵưޤMPLSǤʣΥץ夲ꤷޤCCNACCNPǤѤץ1ĤIDϤĤ1ǹޤ

R2#configure terminal
R2(config)#router ospf 1

˥롼IDꤷޤɬܤǤϤޤ󤬡տޤʤIDˤʤ뤳Ȥ򤱤뤿ꤹ˾ޤǤ礦ǤLo0IPɥ쥹ѤƤޤ

R2(config-router)#router-id 17.17.2.2

Ѥ륤󥿡եꤷޤ

R2(config-router)#network 12.12.12.2 0.0.0.0 area 0
R2(config-router)#network 23.23.23.2 0.0.0.0 area 0
R2(config-router)#network 17.17.2.2 0.0.0.0 area 0

ϸ塢ꤵƤ뤫ǧޤshow running-configdzǧ뤳ȤϤޤΨŪǤϤޤshow ip ospf interface briefμ¤ǤΥޥɤѤ뤳ȤǡOSPFͭˤʤäƤ륤󥿡եΤߤɽ뤳ȤޤޤbriefʤСܺ٤ɽޤ

R2#show ip ospf interface brief
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Lo0          1     0               17.17.2.2/24       1     LOOP  0/0
Se1/2        1     0               23.23.23.2/24      64    P2P   1/1
Fa0/0        1     0               12.12.12.2/24      1     BDR   1/1

F0/0ꤷǤͥåȥפʤɤɽƤ뤳Ȥʬޤ

R2#show ip ospf interface FastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 12.12.12.2/24, Area 0
  Process ID 1, Router ID 17.17.2.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
ά

show running-configdzǧñˤɤΤ褦Ϥ줿ɽ뤫Ǥꡢºݤ˥󥿡եͭˤʤäƤ뤫ǧǤޤ󡣤Фshow ip ospf interfaceǤ꤬ͭˤʤäƤ뤫ǧǤޤ

ޤ¿Υ󥿡եnetwork 0.0.0.0Ȥ뤳ȤƤޤȤͭˤǤޤ

R2(config)#no router ospf 1
R2(config)#router ospf 1
R2(config-router)#router-id 17.17.2.2
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2#show ip ospf interface brief
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Lo0          1     0               17.17.2.2/24       1     LOOP  0/0
Se1/2        1     0               23.23.23.2/24      64    P2P   1/1
Fa0/0        1     0               12.12.12.2/24      1     BDR   1/1

ʤߤnetwork 0.0.0.0 0.0.0.0 area 0ϤƤnetwork 0.0.0.0 255.255.255.255 area 0ꤵޤ

network 0.0.0.0ƤͭˤǤ̤Υ󥿡եǤޤξϸ̤λ꤬ͥŪꤵޤǤF0/0Τߤarea 1ȤʤäȤǧǤޤ

R2(config-router)#network 12.12.12.2 0.0.0.0 area 1

R2#show ip ospf interface brief
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Lo0          1     0               17.17.2.2/24       1     LOOP  0/0
Se1/2        1     0               23.23.23.2/24      64    P2P   1/1
Fa0/0        1     1               12.12.12.2/24      1     WAIT  0/0

󥿡եͭshow ip ospf neighborǥͥСȤ³ǧޤshow ip ospf neighbor detailǤܺ٤ʾɽޤ

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
17.17.1.1         1   FULL/DR         00:00:31    12.12.12.1      FastEthernet0/0
17.17.3.3         0   FULL/  -        00:00:31    23.23.23.3      Serial1/2

ƥ:

OSPFEIGRPȰ㤤BGPǤѹƤ⤹ˤȿǤޤ󡣤ޤΤȤ򤷤Ƥʤȡ꤬ȿǤʤΤϴְäƤΤǺळȤˤʤޤƤΤȤ򤷤ƤСФ餯ԤäƤshow ip bgpdzǧФȤʤΤǤCCIE LabٶǤԤäƤʤʤ餢ޤΤ褦ʾ硢"clear ip bgp"ޥɤѤޤ

R2#clear ip bgp ?
  *                Clear all peers
ά

ǤñʻȤ"clear ip bgp *"Ǥ

R2#clear ip bgp *
R2#
Jan 12 06:00:59.871: %BGP-5-ADJCHANGE: neighbor 12.12.12.1 Down User reset
Jan 12 06:00:59.871: %BGP-5-ADJCHANGE: neighbor 23.23.23.3 Down User reset
Jan 12 06:01:00.915: %BGP-5-ADJCHANGE: neighbor 23.23.23.3 Up
Jan 12 06:01:01.107: %BGP-5-ADJCHANGE: neighbor 12.12.12.1 Up

¹ԤʬޤϤ٤ƤBGPåΥꥻåȤȤʤޤ֤⤫ꡢޤΨŪʻȤȤϸޤ"*"³softꤹȥåϰݻޤޡ򹹿뤳Ȥޤ

R2#clear ip bgp * ?
ά
  soft   Soft reconfig inbound and outbound updates
ά

R2#clear ip bgp * soft ?
  in   Soft reconfig inbound updates
  out  Soft reconfig outbound updates
  <cr>

soft³inޤoutꤹΤߤιȤʤޤ

ϥͥС12.12.12.1Υͥåȥweight 100ˤ¹Ǥ˷̤ȿǤ줿ȤǧǤޤ

R2#show ip bgp
BGP table version is 3, local router ID is 17.17.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.3.0/24    23.23.23.3               0             0 300 i
*> 192.168.1.0      12.12.12.1               0             0 100 i

R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router bgp 200
R2(config-router)#neighbor 12.12.12.1 weight 100
R2(config-router)#^Z

R2#clear ip bgp * soft in
R2#show ip bgp          
BGP table version is 4, local router ID is 17.17.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.3.0/24    23.23.23.3               0             0 300 i
*> 192.168.1.0      12.12.12.1               0           100 100 i

"*"ȤƤΥͥСоݤˤʤޤ¿ΥͥСꤹȤǤ礦

R2#clear ip bgp 12.12.12.1 soft in

ƥ:

ͤBGPơ֥뤬ޤ椫192.168.2.0192.168.3.0Υ롼ȤȴФprefix-listѤޤ

R1#show version | include IOS
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)
R1#show ip bgp
BGP table version is 27, local router ID is 17.17.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.0.0      12.12.12.2               0             0 200 i
*> 192.168.1.0      12.12.12.2               0             0 200 i
*> 192.168.2.0      12.12.12.2               0             0 200 i
*> 192.168.3.0      12.12.12.2               0             0 200 i

R1#show running-config | include LIST1
ip prefix-list LIST1 seq 5 permit 192.168.2.0/24
ip prefix-list LIST1 seq 10 permit 192.168.3.0/24

R1#show ip prefix-list LIST1
ip prefix-list LIST1: 2 entries
   seq 5 permit 192.168.2.0/24
   seq 10 permit 192.168.3.0/24

꤬ͭǤ뤫ɤshow ip bgp prefix-listȤȴñ˳ǧ뤳ȤǤޤ

R1#show ip bgp ?
ά
  prefix-list        Display routes matching the prefix-list
ά

R1#show ip bgp prefix-list LIST1
BGP table version is 28, local router ID is 17.17.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.2.0      12.12.12.2               0             0 200 i
*> 192.168.3.0      12.12.12.2               0             0 200 i

LIST12ԤꤷƤޤ1Ԥǽ񤱤Ȥ꤬꤬ǤLIST2ͤ˽񤱤ʤϤǤƱˡǻƤߤޤ

R1#show running-config | include LIST2
ip prefix-list LIST2 seq 5 permit 192.168.2.0/23 le 24

R1#show ip prefix-list LIST2
ip prefix-list LIST2: 1 entries
   seq 5 permit 192.168.2.0/23 le 24

R1#show ip bgp prefix-list LIST2
BGP table version is 28, local router ID is 17.17.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.2.0      12.12.12.2               0             0 200 i
*> 192.168.3.0      12.12.12.2               0             0 200 i

ʤ褦Ǥˤ2Ĥroute-mapȤweightꤷƤߤޤsequence 100weightꤷʤ롼ȤΤɬפǤ

R1#show running-config | section route-map
route-map WEIGHT permit 10
match ip address prefix-list LIST2
set weight 100
route-map WEIGHT permit 100

R1#show route-map WEIGHT
route-map WEIGHT, permit, sequence 10
  Match clauses:
    ip address prefix-lists: LIST2
  Set clauses:
    weight 100
  Policy routing matches: 0 packets, 0 bytes
route-map WEIGHT, permit, sequence 100
  Match clauses:
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes

R1#show running-config | section bgp
router bgp 100
ά
neighbor 12.12.12.2 route-map WEIGHT in
ά

嵭weightꤵ줿ȤʬޤΤ褦show ip bgp prefix-listȤȤprefix-listտޤ̤ˤʤäƤ뤫ǧ뤳ȤǤޤ

R1#show ip bgp
BGP table version is 36, local router ID is 17.17.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.0.0      12.12.12.2               0             0 200 i
*> 192.168.1.0      12.12.12.2               0             0 200 i
*> 192.168.2.0      12.12.12.2               0           100 200 i
*> 192.168.3.0      12.12.12.2               0           100 200 i
*> 192.168.4.0      12.12.12.2               0             0 200 i

ΥڡΥȥåץ

Ф