2010ǯ12

ƥ:

ǯCCIEٶϤФäΤǡǯϽϤϤޤȤȤǥ᡼ޥϤƤߤޤCiscoϢLinuxϢϷ빽ޤξޤȤưäƤ᡼ޥ̵褦ʤΤǡʤΩĤȻפޤġ

1󡢿ȯԤǤʤȤ2011ǯդ³Ĥꡣ˾Ϥ餫ϿƲ̵Ǥ

ͥåȥȥФ

ץŪˤäȼ䤷äΤ"Linux Tips""YouTube"ȤܤɲäƤߤޤ

¼ۤȯԤޤХåʥСϤ餫餴ޤ

ͥåȥȥФ ХåʥС

ꥹޥץ쥼

ƥ:

Ccie_plaqueUPSꡢʪȯޤȥ᡼뤬ϤȯԤCiscoȤȤϤ줷ʤġȥå󥰥ʥСɤäƤȺĶ夷ϤΤʤȻפäƤ顢15᤮ˤãλä®͡ϤΤ10-12ָȤꡢǯͽۤƤΤǻפʤꥹޥץ쥼Ȥˤʤޤ

ȤϤ󤳤졢CCIEʼԤ(ʤߤ˱ѸǤ"plaque")Ǥäȹʤ´ǤνΤˤɤλ֤Ȥ䤷ȤġߡΤɤˤ뤫װ档

ʤߤˤνΥǥϸߤΤΤ5餷Υǥ̣᤮Ȥ¿ä褦ǡΥդȤʬ䤹ǥˤʤäߤ

ƥ:

IOSǥե졼졼򤹤ݤmap-class褯ȤޤͤγǧϤɤФΤǤ礦class-mapǤФΤޤshowޥɤǻǤޤƱȤmap-classǼ¹Ԥȥ顼ȤʤޤǼʤǤ͡ġ

R1#show version | include IOS
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)
R1#show class-map
Class Map match-any class-default (id 0)
   Match any

Class Map match-all MYCLASS (id 1)
   Match input-interface Loopback0

R1#show map-class

% Invalid input detected at '^' marker.

map-classǧˤshow running-configѤޤ

R1#show running-config map-class
Building configuration...

Current configuration:
!
map-class frame-relay FRTS
frame-relay cir 192000
frame-relay bc 19200
end

"show running-config | begin map-class"ȤƤŪˤƱǤ

ƥ:

IOSǥ롼ʤɤԤäƤȤˡľե(running-config)򸫤뤳Ȥޤshow running-config򤽤Τޤ޼¹ԤΤϤޤȤϸޤ٤롼Ǥл֤뤷⤽ΤɽɬפʬõΤݤǤ

ѥ"|"Ѥ뤳Ȥǡrunning-config긫䤹뤳ȤǽǤ

R1#show version | include IOS
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)
R1#show running-config | ?
  append    Append redirected output to URL (URLs supporting append operation
            only)
  begin     Begin with the line that matches
  exclude   Exclude lines that match
  include   Include lines that match
  redirect  Redirect output to URL
  section   Filter a section of output
  tee       Copy output to URL

㤨OSPFǧ"begin"Ȥޤ"begin"ΰ˻ꤷʸ˰פ԰ʹߤɽ뤳Ȥʬޤ

R1#show running-config | begin router ospf
router ospf 1
router-id 17.17.1.1
log-adjacency-changes
network 12.12.12.1 0.0.0.0 area 0
network 17.17.1.1 0.0.0.0 area 0
!
ά

嵭OSPFͤǧǤޤ"include"ѤȰ˻ꤷʸޤԤΤߤɽǤޤ

R1#show running-config | include ospf
ip ospf priority 0
router ospf 1

嵭ǥ󥿡ե˥ץ饤ƥꤵƤ뤳Ȥʬޤ"section"ѤȴϢͤޤȤɽǤޤ

R1#show running-config | section ospf
ip ospf priority 0
router ospf 1
router-id 17.17.1.1
log-adjacency-changes
network 12.12.12.1 0.0.0.0 area 0
network 17.17.1.1 0.0.0.0 area 0

󥿡եǧˤϥѥפפǡΤޤޥ󥿡ե̾ꤷޤ

R1#show running-config interface fastEthernet 0/0
Building configuration...

Current configuration : 94 bytes
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
speed 100
full-duplex
end

Ǹ"linenum"ꤹȹֹɽǽǤ

R1#show running-config linenum
Building configuration...

Current configuration : 1525 bytes
     1 : !
     2 : ! Last configuration change at 15:48:13 JST Mon Dec 20 2010
     3 : !
     4 : version 12.4
     5 : service timestamps debug datetime msec
ά

ƥ:

Cisco IOSǥꥹȤѤ硢ꥹȤꤵƤ뤫ɤΤ褦˳ǧФǤ礦Τ褦ʥ롼ƥ󥰥ơ֥뤬ޤ

R1#show version | include IOS
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)
R1#show ip route ospf
     17.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       17.17.3.3/32 [110/66] via 12.12.12.2, 02:52:18, FastEthernet0/0
O       17.17.2.2/32 [110/2] via 12.12.12.2, 02:52:18, FastEthernet0/0
O E2 192.168.8.0/24 [110/20] via 12.12.12.2, 00:05:04, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
O       23.23.23.0 [110/65] via 12.12.12.2, 02:52:18, FastEthernet0/0
O E2 192.168.4.0/24 [110/20] via 12.12.12.2, 00:05:17, FastEthernet0/0
O E2 192.168.5.0/24 [110/20] via 12.12.12.2, 00:05:15, FastEthernet0/0
O E2 192.168.6.0/24 [110/20] via 12.12.12.2, 00:05:11, FastEthernet0/0
O E2 192.168.7.0/24 [110/20] via 12.12.12.2, 00:05:08, FastEthernet0/0
O E2 192.168.0.0/24 [110/20] via 12.12.12.2, 02:51:11, FastEthernet0/0
O E2 192.168.1.0/24 [110/20] via 12.12.12.2, 02:51:11, FastEthernet0/0
O E2 192.168.2.0/24 [110/20] via 12.12.12.2, 00:05:22, FastEthernet0/0
O E2 192.168.3.0/24 [110/20] via 12.12.12.2, 00:05:20, FastEthernet0/0

Ǥ192.168ǻϤޤͥåȥоݤȤޤ4ĤΥꥹȤޤ3ƥåȤͤ0, 1, 3, 7ȤƤޤ

R1#show ip access-lists
Standard IP access list AC1
    10 permit 192.168.0.0, wildcard bits 0.0.0.255
Standard IP access list AC2
    10 permit 192.168.0.0, wildcard bits 0.0.1.255
Standard IP access list AC3
    10 permit 192.168.0.0, wildcard bits 0.0.3.255
Standard IP access list AC4
    10 permit 192.168.0.0, wildcard bits 0.0.7.255

show ip route³listꤹ뤳ȤˤꥢꥹȤꤹ뤳ȤǽǤꥹȤ򤳤ǻꤹ뤳Ȥˤꡢտޤͥåȥɽ뤫ǧ뤳Ȥޤ

R1#show ip route ?
  Hostname or A.B.C.D  Network to display information about or hostname
ά
  list                 IP Access list
ά

¹ԤȡꥹȤΥ󥿡ͤ뤳Ȥʬޤ

R1#show ip route list AC1
O E2 192.168.0.0/24
R1#show ip access-lists AC1
Standard IP access list AC1
    10 permit 192.168.0.0, wildcard bits 0.0.0.255 (1 match)

R1#show ip route list AC2
O E2 192.168.0.0/24
O E2 192.168.1.0/24
R1#show ip access-lists AC2
Standard IP access list AC2
    10 permit 192.168.0.0, wildcard bits 0.0.1.255 (2 matches)

R1#show ip route list AC3
O E2 192.168.0.0/24
O E2 192.168.1.0/24
O E2 192.168.2.0/24
O E2 192.168.3.0/24
R1#show ip access-lists AC3
Standard IP access list AC3
    10 permit 192.168.0.0, wildcard bits 0.0.3.255 (4 matches)

R1#show ip route list AC4
O E2 192.168.4.0/24
O E2 192.168.5.0/24
O E2 192.168.6.0/24
O E2 192.168.7.0/24
O E2 192.168.0.0/24
O E2 192.168.1.0/24
O E2 192.168.2.0/24
O E2 192.168.3.0/24
R1#show ip access-lists AC4
Standard IP access list AC4
    10 permit 192.168.0.0, wildcard bits 0.0.7.255 (8 matches)

󥿡clearޥɤǥꥻåȲǽǤ

R1#clear ip access-list counters

ƥ:

Linux Dynamips 򥤥󥹥ȡ뤹ǤʲκȤCentOS 5.5ǹԤäƤޤץץȤ"$"ϰ̥桼"#"root桼̣ޤ

$ cat /etc/redhat-release
CentOS release 5.5 (Final)

Dynamips
http://www.ipflow.utc.fr/blog/?p=52

ΥȤDynamipsɤޤʬѤƤCPUǧˤunameޥɤѤޤ

$ uname -m
x86_64

ɤˤwgetޥɤǤ礦

$ cd /tmp
$ wget http://www.ipflow.utc.fr/dynamips/dynamips-0.2.8-RC2-amd64.bin

ɤեϥХʥǤΤޤ޼¹ԤǤޤܥådynamipsǵư褦ˤǤ礦

# chmod +x dynamips-0.2.8-RC2-amd64.bin
# ls -lh dynamips-0.2.8-RC2-amd64.bin
-rwxrwxr-x 1 cisco cisco 994K Oct 14  2007 dynamips-0.2.8-RC2-amd64.bin

# cp /tmp/dynamips-0.2.8-RC2-amd64.bin /usr/local/bin
# ln -s /home/fumi/bin/dynamips-0.2.8-RC2-amd64.bin /usr/local/bin/dynamips

DynamipsưѤTCPݡȤꤷޤǥ奢륳ǤХץ2ĵưޤNICIPɥ쥹Ƥݤˤdynamipsroot¤Ǽ¹ԤƤɬפޤ

$ dynamips -H 7200 &
$ dynamips -H 7201 &

DynamipsԤDynagenɤޤե롢dynagen-0.11.0.tar.gzѤޤ

Dynagen
http://sourceforge.net/projects/dyna-gen/files/

⡢ɤˤwgetޥɤǤ礦

$ cd /tmp
$ wget http://sourceforge.net/projects/dyna-gen/files/dynagen%20source%20_%20Linux/dynagen%200.11.0/dynagen-0.11.0.tar.gz/download

षեϥХʥǤΤޤ޼¹ԤǤޤܥådynagenǵư褦ˤǤ礦

# tar zxvf /tmp/dynagen-0.11.0.tar.gz -C /usr/local/src/
# chmod 755 /usr/local/src/dynagen-0.11.0/dynagen
# ls -lh /usr/local/src/dynagen-0.11.0/dynagen
-rwxr-xr-x 1 501 501 97K Apr 20  2008 /usr/local/src/dynagen-0.11.0/dynagen

# ln -s /usr/local/src/dynagen-0.11.0/dynagen /usr/local/bin/dynagen

ǸIOSŬʥǥ쥯ȥ¸(Ǥ/var/cisco)Τ褦եǵưǤ뤫ǧޤ

$ cat /tmp/dynamips_test.net
[localhost:7200]

    [[3725]]
        image = /var/cisco/IOS3725.BIN
        ram = 256

    [[ROUTER R1]]
        model = 3725
        console = 2001

[localhost:7201]

    [[3725]]
        image = /var/cisco/IOS3725.BIN
        ram = 256

    [[ROUTER R2]]
        model = 3725
        console = 2002

$ dynagen /tmp/dynamips_test.net

$ telnet localhost 2001
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connected to Dynamips VM "R1" (ID 0, type c3725) - Console port

ƥ:

Ϥ
ǰʤ̵̤˻ŤͤơäȤΤȤCCIE Lab(R&S)˹ʤ뤳Ȥޤ볧󤬡̵̤ʻ֤ȤȤʤƤ褦3ǼϤٶˡ񤤤Ƥߤޤ

Blueprint
ޤϰϤ򤹤뤳ȤפǤBlueprint˽񤤤Ƥ뤳ȤϤ٤ƽФȤٶޤCisco Documentation餽줾ιܤõФPDF¸Ƥȥե饤ǤٶΩĤǤ礦Cisco PressʤɤνҤRFCʤɤɤޤ

½
褽μ顢ȤäƳؽϤޤINEIPexpertΥ֥åȤΤŪǤINEѤΤǡʹߤINEǤäȤʤޤ

INEΥ֥åVolume 14ޤǤޤ12פǤ1Ƶξܺ٤ʼ½220ΥեܤǤμ½Ȥʤޤơʤ֥åVolume 2(ե)ȤäƤϤޤVolume 1Ϥޤǽ餫Volume 2Ȥȡ줾εѤȾüˤʤޤϤǼԤޤ

ʤΥեܤɤ񤷤´뤿Volume 2, Lab 1ȤꤢƤߤΤ⤤⤷ޤ󥿥åȤȽñǤϽƻˤޤʣ˵㤭ˤʤޤLab 1Ǥ٥뤬㤤Τ˾ŪˤʤޤLab 1Υ٥10ʳ5ǤºݤCCIE Labϥ٥7٤ȴ¿褦Ǥ٥7ȴޤ

ʤߤ˥եܤϽƤξ硢򸫤ʤ饳ޥɤϤƤ2-3֤ϷڤȻפޤ

եܤʣ򤷤Volume 1ȤƵ(Switching, RIP, OSPFʤ)ĤĻ֤򤫤򤹤뤳ȤϤޤ礦Ū˻֤ϤʤϤǤ

ޤǽ˥åϤޤL2Ǥʤȥ롼ƥ󥰤䤽¾ΤΤϤޤä꤬ǤʤȤäƲǤϤޤCatalystµȤ֤򤫤Ʒ֤Ԥޤ

θRIPOSPFʤɤΥ롼ƥ󥰤˿ʤߤޤCCIE LabǤϥåȥ롼ƥ󥰤100%ʤȤܹۤʤϤޤ󡣴ŪʵѤϤ餵򤹤뤳ȤפǤ

θMulticastMPLSQoSؿʤ櫓Ǥ˶֤ޤġޤʤˤФ뤳ȤΤȻפȤǤ礦

Volume 1̤ؽVolume 2Υեܤĩ路Ƥߤޤlab 20ޤǤޤ֤ε¤ꡢ֤½򷫤֤ޤLab 20ޤǤ٤ơ򸫤˽褦ˤʤΤŪǤ

ٶ򤷤ƤȤ褯ʬʤΤȤʤФƤޤλ˽פʤȤϡĴ٤ȤGoogleʤɤθ󥸥ϻȤʤȤȡʤʤС˸Ͻʤġ饤ΥɥȤϤĤCisco Documentation󥯤éäĴ٤ʤĤޤ礦Cisco Documentationʣʹ¤ǡ򤹤Τ˻֤ޤʤѤƤȡλˤϤɤˤΤȤȤǺޤˤǤ礦ٶCisco PressRFCĴ٤ޤ

к饹Ƥߤ
ȳؤϸΨΤǡCCIEݻԤʤϰ٤к饹뤳Ȥᤷޤʬʤ֤ǼƤϤ̵̤ǤΤǡVolume 1̤ٶơVolume 2򾯤Ƥ餬Ǥ礦ʵ˻פäƤʤɤޤȤƹֻդ˼䤹Сʬ˸ϼȻפޤ(ϼƤʤΤǴ˾Ū¬Ǥ)ޤCCIEʼԤɤΤ褦ԤȤȤܤǸȡʬΥ٥뤬褯İǤϤǤ

ȥ֥륷塼ƥк
INEΥ֥åǤVolume 4ȥ֥륷塼ƥ󥰤ȤʤޤǥХޥɤβ⤬ΩĤΤǤVolume 4ϤʤƤʤȻפޤ̾ٶˤƤΥޥɤʤȤɤʤ뤫A٤ȤBȤȤɤʤ뤫Ȥʤ鷫֤Ȥб褦ˤʤ뤿Ǥ

٥פ
ʬεʬǻƤϤޤɬƤ⤤٥ˤʤäȤǧƤ顢ꤷޤ֤ǻȡƤΤޤäǤ˽ǽ⤤ΤǤٻƤޤäʤͤǡλ֤Ԥ˵äƤޤäޤ虜虜񤫤Τ˿ɤ褿褦Ǥġ

ʬΥ٥פ뤿ˤMock LabŬǤ礦ȤޤäƱ褦30ʬεٷƤ򶴤ߡפ8֡CiscoDocȤäƻƤߤޤ60ټлʤ٥ǤʤºݤιǤ80ǤϤʤ60ȤȡMock Labϼºݤλ񤷤ƼºݤλޤǼǤ뤫Ǥʤߤ˻䤬Ǹ˼Ȥ58Ǥ


ºݤ˻Ϥ᤿顢ʤޤ³뤳ȤᤷޤȾǯʤɴ֤֤ȡδФ᤹Ȥ˻֤ޤΤǤǤޤ1ܡ2ܤλˤäٶ֤ɬפǤ3ϻŻ˻ʤޤŬ٤ߤ֤Ѱդޤ礦

1
Ȥˤս񤭤ޤƷ֤ɤߤޤ礦򤷤Ƥ褯ơ򤷤ƤϤʤΤ褯褦ˤޤơ򸫤Ȥۤ񤷤ϤʤΤǤ줬ˤɤͤ˴ϢƤ뤫ȤפǤǤ¤٤ޤǵޤλϤΤޤ失˰ươϿޤ

ޤΤȤʤѴĶʬʹԤäƤΤȰۤʤޤüˡǧޤ礦եȤΥʤɤѹ뤳ȤǽǤ

̤ϤۤȤɤξ硢λ12ְϤޤ򸫤ơǤɤְ㤤Ǥä¬ޤҤȷλޤǡΥƥ򤹤٤ƲϤƥߥ졼򷫤֤ޤ礦ʤߤ˹ʤˤΨϤޤ

2
2ܤҤ̤򤭡1-2֤θľ֤ĤȤɸǤϤǤ¤국ƵϿޤ

1ܤƱ褦ˡƥƤ򤹤٤ƲϤƥߥ졼򷫤֤ޤټޤλѥɤ褦ˤʤϤǤ

3
3ܤϤ󡢹ʤܻؤޤ褯ɤǿŤԤޤȤˤǤְ㤤Ƚ˻֤礬Τǡľλ֤׻Ƴμ¤˿ʤޤ礦

λϤԹʤȤǰη̤Ͽޤʤޤǵȴ³뤳Ȥᤷޤٵ٤Ǥޤȸ᤹ΤȤˤѤʤΤǡġ


ǸˤʤޤäȤפʻ"ᥲʤ"äꤷޤʤޤĹ֡ٶ³ΤѤʤȤǤŪ˻֤ꡢLabΤٶϤ1ǯȾ⤯餤ǹʤܻؤΤ˾ޤǤ礦

ΥڡΥȥåץ

Ф